Highlighted
Valued Contributor.. hemantd18 Valued Contributor..
Valued Contributor..
430 views

Loading screen freezes after logging in to Asset Manager 9.32

We are facing an intermittent issue for few users while accessing the HP Asset Manager Web console, where the screen will freeze after login. There are several other users able to access HPAM Web console without any issues though. No errors/exceptions detected in the logs of web servers (tomcat/siteminder logs)

HP Asset Manager 9.32 build 9774, Oracle DB, HP AM web running on two web servers with linux platform

 

 

 

0 Likes
9 Replies
Trusted Contributor.. egregoire Trusted Contributor..
Trusted Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

Hi hemantd18,

Usually, when only a few operators have this kind of problem, that means that it's certainly related to the definition profile used for these users.
Check the global definition of the role (domain + profile).

BR
Eric
0 Likes
Valued Contributor.. hemantd18 Valued Contributor..
Valued Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

Thanks for the reply.
We have tried assigning several other profiles including administrator to the troubled users, that also didn't worked. Any idea what could be causing this behavior?
0 Likes
Trusted Contributor.. egregoire Trusted Contributor..
Trusted Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

  • Before this trouble happens, do you have made some modification of the AM structure? 
  • Did you have tried to remove all Tomcat instance caches?
  • Did you have tried to reproduce this problème on test/acceptance platform?
  • Did you have seen something in web log files?

At this point, we need more pieces of information on your problem.

0 Likes
Valued Contributor.. hemantd18 Valued Contributor..
Valued Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

Per my understanding, if there were any issues in the configuration due to recent changes that would cause this issue then it should be for all the users across organization. We got this issue currently reported by two-three users only.

We have tried bouncing the Webserver/tomcat several times, which didnt helped so far. Also tried to reproduce/compare the log files for working user and user with issues (smtrace.log, webagent.log, ssl_access_log, etc) unfortunately the entries recorded were similar in both cases.

0 Likes
Trusted Contributor.. egregoire Trusted Contributor..
Trusted Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

You are right, except if your two or three users are sharing the same screen/object. (eg : action/wizard at the connexion).

Regarding Tomcat, did you have stopped Tomcat instance and removed all cache files?

But, I think that the problem is directly related to users records.
Did you have tried to reproduce it with the binary client? -Using login/password of one of your users-
It's a good way to see what's happening by using adblog tracking on a fat client.

0 Likes
Trusted Contributor.. egregoire Trusted Contributor..
Trusted Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

One more, did you contact your DBA, to check if Oracle logs have some information regarding queries tracking or response time.

If the problem is happening at the connexion momentum, perhaps the database engine keeps the trace to this connexion (AM API queries).

0 Likes
Valued Contributor.. hemantd18 Valued Contributor..
Valued Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

Sorry for delayed response. We had tried to clear the cache, bounce tomcat on our Linux web servers unfortunately that still didn't worked. The issue still persists. In addition, we also checked with the Active Directory profile and Siteminder authentication as well, nothing significant noticed. Also, the user was able to access the Webservices page from his system.

0 Likes
Trusted Contributor.. egregoire Trusted Contributor..
Trusted Contributor..

Re: Loading screen freezes after logging in to Asset Manager 9.32

hi hemantd18,

Sorry I was AFK for some days.
Have you checked if these AM users have in AM some script action running at the AM connection?

In some case that may have a negative impact when a user is connecting AM through the web application.

Have you tried to see what's happening when these users login are used with a fat/heavy client?

0 Likes
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: Loading screen freezes after logging in to Asset Manager 9.32

Hello,

Don't you consider maybe an upgrade? AM 9.32 is obsolete now. But apart of that, the latest versions has quite some improvements. (as you can imagine)

I highly recommend you to think about this option. 🙂

 

https://docs.microfocus.com/itom/Asset_Manager:9.70/Home

-------------------
Boryana Kotseva
Micro Focus Senior Technical Support Engineer / NSE
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.