There was an error with the search service. Search term is in an invalid format

There was an error with the search service. Search term is in an invalid format

After running a search in Atlas, zero results are returned and the following error is displayed:

This is caused by a corrupted search index or database.

To resolve:

  • Open services.msc and locate the service "StarTeam Server - AtlasSuite" and stop it.
  • Also stop the service called "Hub Search Web Service 15"
  • Browse to your CM Hub installation directory under Program Files and enter the folder named Repository.
  • Move the folders named "SearchIndex" and "SearchDB" to another location.
  • Start the Borland Atlas Web Service service.
  • Launch the CM Hub Administration console and click Configure Search


  • Check the box "Enable search for StarTeam Server" and click OK
  • In services.msc restart the service "StarTeam Server - AtlasSuite"

Once all services have restarted, search will now function correctly in Atlas.

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Version history
Revision #:
1 of 1
Last update:
‎2016-04-06 15:26
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.