Highlighted
Honored Contributor.
Honored Contributor.
1378 views

ASM failing with error message

Hello All 

We are trying to ASM out OMi server and it is failing with the error message :

Failed executing script, details: Traceback (most recent call last): File "", line 2, in  File "host_discovery", line 43, in DiscoveryMain File "host_discovery", line 91, in reportErrors File "asm_error_filter", line 27, in filterErrors File "asm_error_filter", line 77, in handle File "asm_error_filter", line 99, in createNewErrors AttributeError: 'module' object has no attribute 'ERROR_CREDENTIAL'

 

Also attached communication log . Not sure why it is trying to connect through UDA Protocol . 

 

Regards 

Arpit

Tags (1)
0 Likes
10 Replies
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: ASM failing with error message

Hi

I have noticed the following error in your communication log:

CDATA: NTCMD connection: access is denied

So could you please do the following on your probe:

1. Go to windows services and find UCMDB Data Flow Probe service. Double click the data flow probe service item to open the properites windows

2. Goto "Log On" tab of data flow probe service tab

3. By default, the "Log On as" option should be "Local System account", change it to the domain account which normally used to login to probe machine.

 Input the password of this account, save the changes.


4. Restart the probe services.

 

If you have already done this in your probe could you please check your EventViewer if you have any error related to the probe services

Hope this helps

 

Best Regards

Yasser

 

 

 

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: ASM failing with error message

Hello Yasser

 

No, its still the same . Same error message persists . It seems It is trying to connect through ntcmd protocol . I have tried accessing  the ADMIN$ from the probe, but I am not able to . As per the system team , ntcmd user has all the access from accessing the ADMIN$ . 

Can you please help to troubleshoot further . 

Regards 

Arpit

Tags (1)
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: ASM failing with error message

Hi Arpit

Are you sure that the credentials used in the NTCMD protocol are correct ? and that the IP of your OMI server is included in the NTCMD protocol IP range.

If it is ok from this side then could you try to test if the ASM works when you change the entry point url to HTTP and not HTTPS (and of course change the corresponding ports number)

Best Regards

Yasser

0 Likes
Highlighted
Frequent Visitor.

Re: ASM failing with error message

Hi Arpit,

May I know the Content Pack version? And did you deploy the ASM_Enhanced.package separately or deply the entire content pack?

For windows NTCMD credentials issues, I suggest we need to check the shared folder for this user in target machine.

Please run “net share” to show all shared folder, and if there is no ADMIN$ is shared, this target machine will not be accessed by this credential.

netshare.jpg 

If there is ADMIN$ which is for Remote Admin in net share results, this target machine can be accessed by NTCMD credential.

netshare2.jpg

 Best Regards,

Tony

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: ASM failing with error message

Hi Yasser

NTCMD credentials are fine . Strange issue what I am seeing now is .. When I do a credentila check for NTCMD protocol it fails with error message : Access Denied , but when I try to run the hpcmd.exe utility from the probe I am able to establish connection to the OMI server perfectly fine . Even able to acess the ADMIN$

 

Any thoufghts ?

 

Regards 

Arpit

Tags (1)
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: ASM failing with error message

Hi Tony 

Its UD 10.22 CUP6 CP24 .  NTCMD credentials are fine . net share command shows ADMIN$ is available .  Strange issue what I am seeing now is .. When I do a credentils check for NTCMD protocol it fails with error message : Access Denied , but when I try to run the hpcmd.exe utility from the probe I am able to establish connection to the OMI server perfectly fine . Even able to acess the ADMIN$

 Any thoufghts ?

 Regards 

Arpit

Tags (1)
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: ASM failing with error message

HI Arpit

I have found the following suggestion in the UCMDB help center (http://cmshelpcenter.saas.hp.com/CMS/10.21/cp-docs/docs/eng/doc_lib/Content/NBD_R_HCSHELL_ts.htm)

"This appears if the user attempting to discover the destination host is not a local Administrator user. (It does not matter if the user is a member of the Administrators group.)

Solution: The solution requires additional configuration of the security policy.

The LocalAccountTokenPolicy key should be changed to allow users from the Administrator group to connect remotely with Administrator privileges. Run the following command in PowerShell on the discovered host:

Set-ItemProperty -Path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\
Policies\System -Name LocalAccountTokenFilterPolicy -Value 1 -Type DWord

For details of this special case, see "HOW TO ENABLE REMOTING FOR ADMINISTRATORS IN OTHER DOMAINS" at http://technet.microsoft.com/en-us/library/dd347642.aspx."

Hope this may help you

Best Regards

Yasser

 

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: ASM failing with error message

Hi Yasser 

This seems valid for servers running on windows 2008 R2 . 

We have OMI server running on Win server 2012  R2

Regards 

Arpit

Tags (1)
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: ASM failing with error message

Hi Arpit

Yes this is valid for Destination Servers (Not OMI server) running on windows 2008 R2, are your destination servers running also on windows 2012 ?

Best Regards

Yasser

0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: ASM failing with error message

Hi Yasser 

Yes my destination server is runnning on Win 2012 R2 and I am trying ASM for OMI only . Hence my destination server is OMI 🙂 

 

Regards 

Arpit

Tags (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.