Highlighted
Trusted Contributor.
Trusted Contributor.
216 views

After upgrading from ucmdb 10.00 to 10.01 the appserver doesn't come up !!

Jump to solution

Dear experts,

trying to upgrade from ucmdb 10.00 to 10.01 on windows the ucmdb server doesn't start up anymore. Error Msg. in "start.log":

 

"2013-11-12 14:55:59,620 [Starter for "topology-search" to Active mode. (customer 1, id name: Default Client)] Failed to start component [topology-search] java.lang.NoClassDefFoundError: org/apache/solr/client/solrj/SolrServer"

----------------------------------------------

 

The Server Status-Page shows every submodule started except the following: + "content-install" module is "not started" + "folders" module is "not started" + "packaging" module is "not started" + "topology-search" module  is "failed"

----------------------------------------------

 

Even the JMX version request Mbean failed with:

Mbean: UCMDB:service=Content Pack Services. Method: displayCurrentContentPackVersion

Operation failed! appilog.framework.shared.manage.impl.MamResponseException: [ErrorCode [-2147483648] undefined error code] Null subsystem manager for name: Content install task [Operation: appilog.framework.shared.content.install.operation.GetCurrentContentPackVersion@64d29f6] : class com.mercury.topaz.cmdb.shared.base.CmdbException : CMDB Internal Error: Error while handling request: {request: ID='66d9edb9ae9e6a28c96ec3a0dadf6258' Message='General CMDB request' Operation='appilog.framework.shared.content.install.operation.GetCurrentContentPackVersion@64d29f6' Customer ID='1' Context='CMDB Context: Customer id = '1' , User ID = '1' , Caller Application = 'JMX''}

----------------------------------------------

 

I worked along the release notes when upgrading, so I don't know what went wrong.

 

Please advice on how to remedy that problem,

 

Thank you very much in advance,

Roman Zillek

0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.
Absent Member.

Re: After upgrading from ucmdb 10.00 to 10.01 the appserver doesn't come up !!

Jump to solution

Hello Roman,

 

Can you please upload the upgrade log, error.log, ui-server.log? Also can you please send the solrconfig.xml from hp\UCMDB\UCMDBServer\search\solr\customer1\conf ?

 

Best regards,

Andrei Matei

Best regards,
Andrei Matei
uCMDB Support Engineer

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

View solution in original post

0 Likes
2 Replies
Highlighted
Absent Member.
Absent Member.

Re: After upgrading from ucmdb 10.00 to 10.01 the appserver doesn't come up !!

Jump to solution

Hello Roman,

 

Can you please upload the upgrade log, error.log, ui-server.log? Also can you please send the solrconfig.xml from hp\UCMDB\UCMDBServer\search\solr\customer1\conf ?

 

Best regards,

Andrei Matei

Best regards,
Andrei Matei
uCMDB Support Engineer

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

View solution in original post

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: After upgrading from ucmdb 10.00 to 10.01 the appserver doesn't come up !!

Jump to solution

Hello Roman Zillek,

 

According to the error messages you provided there is an issue with the search component. A file seems to be missing.

 

In order to progress with the investigation we need the following logs to see the entire stack-trace:

   1. start-up log

   2. error log

   3. cmdb.operation

   4. or zip the entire server logs since they should not be big

 

Please let me know if you have the search-core.jar in UCMDB\UCMDBServer\lib\ folder? If so please upload it too together with the search folder (from UCMDB\UCMDBServer\)

 

Best Regards,

Gabi Medan

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.