Highlighted
Trusted Contributor.
Trusted Contributor.
301 views

Agent driven Inventory manual deployment

Hello all,

I'd like to know if it's possible to manually deploy the UDA in agent driven mode on a windows pc.

I've tried to follow the documentation and I've installed the UDA first, then I've inserted the registry keys

into : HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Hewlett-Packard\Universal Discovery\V1\Options in particular SCHEDULER_Enabled to True and the probe restapi info in SCHEDULER_ProbeBaseURL.

But when I look into the discagnt.log I see this error reported every few seconds:

05-22-19 13:43:51: Warning: The key pass is empty, the agent might not be installed properly.
05-22-19 13:48:54: Error: can't open file 'c:\windows\syswow64\config\systemprofile\appdata\roaming\Micro Focus\Universal Discovery\Data\scanschedule.txt' (error 2: the system cannot find the file specified.)
05-22-19 13:48:54: Warning: No valid scan schedule found in schedule file (c:\windows\syswow64\config\systemprofile\appdata\roaming\Micro Focus\Universal Discovery\Data\scanschedule.txt)

Where I can get ahold of the scanschedule.txt file? Is there a template which can be provided to leverage from? 

What is the error related to the key pass is empty about?

Are there any missing steps to have the full functionality in place ?

Thanks so much in advance for the help

Roberto 

 

    •  
0 Likes
6 Replies
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Re: Agent driven Inventory manual deployment

Hi Roberto,

Have you created scanschedule.txt manually or auto created. It suppose to create automatically. Try to check port from UCMDB probe to target machine on 2738 and from target machine to probe on 9443 port. Also have done the configuration changes on probe server to make the agent driven discovery to be happen?

 

Regards

Annindya

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Agent driven Inventory manual deployment

Hi Annindya,

I've enabled Agent driven inventory discovery job but nothing seems to run , no ci reported. So you mean that this job should be the one in charge to deliver scanschedule.txt to the targeted client?

Which are the modification you mention to be made on probe side?

Regarding the ports do you mean that I should check if the ports are opened between probe and clients?             Other jobs such as Inventory discovery by scanner works perfectly on this client ...

What about the error about the key pass?

 

thanks

Roberto

0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Re: Agent driven Inventory manual deployment

Hi Roberto,

 

for agentdriven first need to modify the DataFlowProbe.properties file with below parameter.

"com.hp.ucmdb.discovery.probe.agents.probegw.agentdrivenflow.twowayssl.enable=true

com.hp.ucmdb.discovery.probe.agents.probegw.agentdrivenflow.custom.port=9443"

Regards

Annindya

 

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Agent driven Inventory manual deployment

Hi Annindya,

I've read what you describe regarding the probe configuration file modification in the section related to deployment via discovery job here:

https://docs.microfocus.com/itom/Universal_CMDB:11.0/dfm/Agent_Deploy_smart_jobs 

what I'm referring to is a MANUAL deployment such as in :

https://docs.microfocus.com/itom/Universal_CMDB:11.0/dfm/Agent_Deploy_smart_Manual

You mean that that prerequisite should be met also in this case? So why the documentation doesn't mentioned this ? 😞

thanks

Roberto

0 Likes
Highlighted
Regular Contributor.
Regular Contributor.

Re: Agent driven Inventory manual deployment

Did you manage to fix this issue?

I am testing out the agent driven agent and experiencing the same issues as yourself.

Thanks

Liam

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: Agent driven Inventory manual deployment

Hello,

the 2 prerequisites are to modify these 2 parameters :

"com.hp.ucmdb.discovery.probe.agents.probegw.agentdrivenflow.twowayssl.enable=true

com.hp.ucmdb.discovery.probe.agents.probegw.agentdrivenflow.custom.port=9443"

in configuration probe file DataFlowProbe.properties 

then restart the probe.

This error is in fact a wrong waming/alert should even be avoided in my opinion :

 Warning: The key pass is empty, the agent might not be installed properly.

If you have correctly installed and configured the client , through the adid job all the needed files included

scheduler.txt containing the frequency that you've set at job level is downloaded and everything should work.

 

I suggest you also to follow this article , especially the debugging part :

https://docs.microfocus.com/UCMDB/11.0/cp-docs/docs/eng/doc_lib/Content/Agent_driven_inventory_troubleshooting.htm

If you still have issues feel free to post here all the relevant files and I can try to help you troubleshooting

regards

Roberto

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.