Highlighted
Established Member..
Established Member..
512 views

Data Flow Probe not connecting to UCMDB server

After installing UCMDB_DataFlowProbe_10.10 on a Windows Server 2008 VM with no errors reported, my UCMDB Probe service can not connect to the UCMDB_Server service.

 

Following the same installation steps has worked OK on several other Windows servers.

 

I can log into the JMX consoles on ports 8080 and 1977, and the UCMDB UI on port 8080 OK.

JMX console viewSystemInformation reports:
     *** System Information ***
     Server version: 10.10 build:620
     OS; Windows Server 2008 R2 version 6.1
     DB: [abc] at SQLServer on [loadbalancer.for.ms.sql.server.com\abc:1433] with userName ...

     HA: Is_enabled = true
          Cluster_name = SQLServer_abc
          Cluster_nodes_names = [MYSERVER_1234567890]
          Cluster_node_number = 1
     Customers [Total of 1 customer(s)]:
          [Customer ID:1, Name: Default Client, CP: 13.0.1179...]
     No probe info found in the system

 

No Probe instance is shown in UCMDB UI, Data Flow Management, Data Flow Probe Setup, Domains and Probes, DefaultDomain, Data Flow Probes.


Every second or so, DataFlowProbe\runtime\log\WrapperProbeGw.log has:
     [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:357) - ProbeGW Tasks confirmer started
     [INFO ] [ProbeGW Tasks Downloader] (JobExecuter.java:1219) - getting All job information took:0 msec
     [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java675) - Confirm Tasks - Sending to Server: []
     [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java675) - ProbeGW Tasks confirmer finished after 15 msec
Then dozens of entries like:
     [INFO ] [ProbeGW Tasks Downloader] (ProbeTasksDistributerPull.java:675) - Probe Gateway received 1 tasks from server. SEND_TOPOLOGY_DATA_TEMPLATE: 0 destinations. Total time to retrieve tasks [15] msec

 

Every 10s DataFlowProbe\runtime\log\security.cmclient.log has:
     [DEBUG] [CMClientConfigurationFilesInitialiserThread] (CMCLient.java:602) - Failed to retrieve LWSSO_INIT_STRING from secured storage (Unable to retrieve from storage encrypted alias: LWSSO_INIT_STRING  Read lock release status:Read loack was successfully released.).


When installing the Data Flow Probe, in the HP UCMDB Data Flow Configurstion dialog, I tried the FQDN, DNS name and IP address for the Application Server address and the Data Flow Probe address.  Pinging the FQDN and DNS name both resolved to the correct IP address.

 

The Windows firewall is off.  The network firewall is not restricting any ports on my Windows VM.

 

The virus protection software has been uninstalled.

 

There is a second network card, but it has been disabled.


Does anyone have any ideas why my Data Flow Probe is not able to communicate with the UCMDB server?
Thanks for any help.

 

Cheers,

Ajit

0 Likes
2 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Data Flow Probe not connecting to UCMDB server

Ajit;

 

Well, has the <DataFlowProbe_Install_Dir>\conf\security\secured_storage.bin file been modified?  It could be we cannot update it due to hardening on the server.   I'd check this:

 

From the probe, look in the <DataFlowProbe_Install_Dir>\conf\DataFlowProbe.properties file and get the following values:

appilog.agent.probe.protocol

serverName

serverPort

serverPortHttps

 

Then open a web browser and using the exact values in the properties file, build the url as follows:

 

<appilog.agent.probe.protocol>://<serverName>:<serverPort or serverPortHttps>/cm/rest

 

You will use serverPort if the protocol is HTTP, and use serverPortHttps if the protocol is HTTPS.  Can you hit that URL from the probe?

 

If not, on the server, check in the JMX console under: UCMDB:service=Ports Management Services and execute 'ComponentsConfigurations'.  Pay attention to:  cm  and mam-collectors.  Look in the 'Current Managed Ports' column and make sure the ports are mapped to the same value the probe has.

 

If all that is okay, then the fastest way to fix this would be to reinstall the probe, make sure the probe is the same version as the UCMDB server.

 

If the new probe still cannot get added to UCMDB, then open a support case.

Hope this helps,
Keith Paschal
UCMDB Worldwide Support Lead
Micro Focus Support
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution."

Click the KUDOS star on the left to say 'Thanks'
Highlighted
Established Member..
Established Member..

Re: Data Flow Probe not connecting to UCMDB server

Thanks Keith, I'll try it now...

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.