Highlighted
Absent Member.. Absent Member..
Absent Member..
132 views

Enrichment rule is not working

Hi,

 

I am using HP UD 10.10 CP: 13.0.1179 on Windows OS.

 

I am creating an Enrichment rule to populate the "Node" CIT attributes in the "Database" CIT. For e.g. I want to populate the "Discovered Model" and "Serial Number" attributes of "Node" CIT into "Database" CIT(I have created custom attributes to populate this data in Database CIT). The Cardinality is set to (Node:Database) as 1:*

 

I am mapping the attribute from Node CIT to Database CIT in the Query Node definition of Enrichment Rules tab for Update action for "Database" CIT.

 

But then the rule is not working as it is not populating the custom attributes with the respective values in the Database CIT.

 

Please help me know with any inputs on this.

 

Thanks in advance

0 Likes
1 Reply
Highlighted
Absent Member.
Absent Member.

Re: Enrichment rule is not working

Hello,

 

I would suggest to filter the TQL to contain just 1 pair. Then you can enable debug for reconciliation logs and cmdb.enrichment from UCMDBServer\conf\log\ folder.IF the problem reproduces upload cmdb.enrichment and cmdb,reconciliation.log.

 

If the TQL contains a lot of CIs you can consider to split the TQL or increase the value of the setting tql.resultutils.chunk.keepingperiod.seconds(it requires a server restart).

 

Best Regards,

Gabi Medan

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.