Highlighted
Absent Member.
Absent Member.
1739 views

Error getting connection from pool

Hello,

 

I am new to uCMDB and trying to set up a test system with it. I currently chose uCMDB 9 as my machine is 32 bit, over a SM9.34.

 

When I get to the point to connect or create a database, no matter I choose new or existing one, I always get "Error getting connection from pool".

 

I have tried:

- Choose Create new database for CMDB and history (error)

- Create 2 SQL databases (ucmdb and history) and grant all permissions to guest user

- Choose "use existing database" and refer to the two created in SQL Server 2005, but still getting the same error.

 

Error getting connection from pool

JDBC Driver Error stablishing socket to host and port: localhost:1433 Reason: Connection Refused Connect.

 

Any ideas how to get over this? Which are the log/config files I should look into?

 

Thanks!

0 Likes
4 Replies
Highlighted
Honored Contributor.
Honored Contributor.

Re: Error getting connection from pool

My first guess is that your SQL Server is not configured to accept TCPIP connections from outside.

Otherwise, there's a chance there's a firewall rule disallowing traffic to or from your database server.

If I were you I'd have a chat with the database and/or network people to get these things verified.

 

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error getting connection from pool

Thanks for the quick reply.

 

SQL sever and ucmdb are installed in the same machine.

I also have Servicemanager on the same, working correctly.

Computer is not part of a domain.

 

is there anywhere else I could look into?

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error getting connection from pool

No one?

 

Basically what I did is:

 

- Take the uCMDB 9.00 iso and install HPUCMDB_Server_90.exe and HPUCMDB_DataFlow_Probe_90.exe

- Then start services and run the wizard to set up the uCMDB server.

 

I assume if I choose to create new DB scheme with SQL server 2005 using the ucmdb wizard, and type in the host name, schema name and port, using windows authentication (which is the one I use to login on SQL Server), nothing else needs to be done right?

Or do I have to configure something on SQL Server 2005?

 

The error I am having is:

 

java.lang.RuntimeException: com.mercury.topaz.cmdb.server.manage.dal.CmdbDalException: [ErrorCode [2] Couldn't connect to database]
Error getting connection from pool
    at com.hp.config_wizard.backend.api.ConfWizServerAPI.createOrConnectSchemas(ConfWizServerAPI.java:64)
    at com.hp.config_wizard.ui.frame.CreateSchemas.onFinish(CreateSchemas.java:238)
    at com.hp.config_wizard.ui.frame.CreateSchemas.access$500(CreateSchemas.java:23)
    at com.hp.config_wizard.ui.frame.CreateSchemas$4.performFinishActions(CreateSchemas.java:203)
    at com.hp.server_tools.common.components.wizard.WizardDlg.onFinish(WizardDlg.java:225)
    at com.hp.server_tools.common.components.wizard.WizardDlg.access$300(WizardDlg.java:27)
    at com.hp.server_tools.common.components.wizard.WizardDlg$5.actionPerformed(WizardDlg.java:105)
    at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
    at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
    at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
    at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
    at java.awt.Component.processMouseEvent(Unknown Source)
    at javax.swing.JComponent.processMouseEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Window.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: com.mercury.topaz.cmdb.server.manage.dal.CmdbDalException: [ErrorCode [2] Couldn't connect to database]
Error getting connection from pool
    at com.mercury.topaz.cmdb.server.manage.dal.ConnectionPoolManager.getConnection(ConnectionPoolManager.java:375)
    at com.mercury.topaz.cmdb.shared.util.dbcreator.CmdbDatabaseCreator.getConnection(CmdbDatabaseCreator.java:190)
    at com.mercury.topaz.cmdb.shared.util.dbcreator.CmdbDatabaseCreator.runDBScript(CmdbDatabaseCreator.java:99)
    at com.mercury.topaz.cmdb.shared.util.dbcreator.CmdbDatabaseCreator.createSchema(CmdbDatabaseCreator.java:76)
    at com.mercury.topaz.cmdb.shared.util.dbcreator.CmdbDatabaseCreator.createSchemas(CmdbDatabaseCreator.java:58)
    at com.mercury.topaz.cmdb.shared.util.dbcreator.CmdbDatabaseCreator.create(CmdbDatabaseCreator.java:34)
    at com.hp.ucmdb.management.impl.DatabaseManagementImpl.createCmdbDatabase(DatabaseManagementImpl.java:50)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.hp.ucmdb.management.impl.CmdbManagementImpl$ContextClassLoaderInvocationHandler.invoke(CmdbManagementImpl.java:76)
    at $Proxy0.createCmdbDatabase(Unknown Source)
    at com.hp.config_wizard.backend.api.ConfWizServerAPI.createOrConnectSchemas(ConfWizServerAPI.java:52)
    ... 31 more
Caused by: com.mercury.topaz.cmdb.shared.base.CmdbException: [ErrorCode [-2147483648] undefined error code]
com.mercury.jdbc.sqlserverbase.BaseSQLException: [mercury][SQLServer JDBC Driver]Error establishing socket to host and port: 192.168.239.129:1433. Reason: Connection refused: connect
    at com.mercury.topaz.cmdb.server.manage.dal.ConnectionPoolManager.getNativeConnection(ConnectionPoolManager.java:356)
    at com.mercury.topaz.cmdb.server.manage.dal.ConnectionPoolManager.getConnection(ConnectionPoolManager.java:370)
    ... 44 more
Caused by: com.mercury.jdbc.sqlserverbase.BaseSQLException: [mercury][SQLServer JDBC Driver]Error establishing socket to host and port: 192.168.239.129:1433. Reason: Connection refused: connect
    at com.mercury.jdbc.sqlserverbase.BaseExceptions.createException(Unknown Source)
    at com.mercury.jdbc.sqlserverbase.BaseExceptions.getException(Unknown Source)
    at com.mercury.jdbc.sqlserver.tds.TDSConnection.<init>(Unknown Source)
    at com.mercury.jdbc.sqlserver.SQLServerImplConnection.open(Unknown Source)
    at com.mercury.jdbc.sqlserverbase.BaseConnection.doConnect(Unknown Source)
    at com.mercury.jdbc.sqlserverbase.BaseConnection.connect(Unknown Source)
    at com.mercury.jdbc.sqlserverbase.BaseConnectionStartup.run(Unknown Source)

 

also when I try to connect to http://localhost:8080/status, tomcat throws an error.

Do I need to deploy any kind of war file?

 

Thanks

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Error getting connection from pool

Somehow I managed to get through the issue.

I created an ODBC driver connection for each database (ucmdb and history), and operators with full access rights to these.

I also checked SQL Server did not have any connecting restriction property.

By some reason the uCMDB Server was stopped, and after several attempts I started it and did go through the steps and created the DBases successfully.

 

EDIT: i narrowed down the issue. I follow this article and everything went smooth, no need to create oodbc connections, etc.

 

https://support.microsoft.com/en-us/kb/914277

 

After following these steps, i created a new configuration and dababases were created succcessfully.

 

 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.