Highlighted
Respected Contributor.
Respected Contributor.
53 views

Excel import issue on 2019.02 CP2020.02

The Excel integration fails to import .xlsx files with this error:

Shell: Internal error. Details:
Traceback (most recent call last):
File "import_from_excel", line 315, in DiscoveryMain
File "xlsutils", line 29, in openXlFile
NoClassDefFoundError: java.lang.NoClassDefFoundError: org/apache/commons/compress/archivers/zip/ZipFile

Any .xlsx from Office365 (or earlier, I also tried Excel 2007) fails with the same error.

Workaround:  Save as .xls (97-2003 excel format), the import is successful.

0 Likes
1 Reply
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Excel import issue on 2019.02 CP2020.02

Hello,

Where any changes done to file xlsutils.py? I do not see any ZipFile class  reference in the ootb script.

The error is simple. The probe does not find in its classpath the appache utility class ZipFile

In case you changed the script you could use  the  java.util.ZipFile.or add the apache package to the probe class path folder.

In case the script was not changed and the documentation steps were followed then submitting a support ticket might be the best approach.

Best Regards,

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.