Super Contributor.. RRose Super Contributor..
Super Contributor..
274 views

Failed to download server data (discoveryResources/ud_scanners/scanwin-x64.exe). No ZipEntry found

Ok, been trying to solve an issue that appears on (2) Windows 2016 probes.  All of my other probes are Windows 2008 and they seem to be working properly. 

I am using UCMDB 10.22 CUP4 CP20 and wanted to upgrade to the latest inventory scanner.  I created a new package with the 2019.02 Windows scanner executable and xml file and deployed.  We have several probes and the package deployed successfully on all of the Windows 2008 probes.  On the 2016 probes I get the following error:

<2019-05-18 20:56:53,352> 82565149 [WARN ] [ProbeGW: DB Tasks Distributor] (DiscoveryClient.java:870) - Failed to download server data (discoveryResources/ud_scanners/scanwin-x64.exe). This was retry #2/10
jvm 1    | java.io.IOException: No ZipEntry found.
jvm 1    |  at com.mercury.topaz.cmdb.shared.util.Zipper.unzip(Zipper.java:166)

Obviously the deploy didn't work, but now these probes will not trigger any inventory by scanner jobs.  Any ideas how I might fix this issue?  Is there a way to manually deploy this new scanner and clear this error?

Thanks,

0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Re: Failed to download server data (discoveryResources/ud_scanners/scanwin-x64.exe). No ZipEntry fou

This configuration is not supported.

I presume it's failing due to a timeout.

Kind regards,
Bogdan Mureșan
EMEA CMS Technical Success
0 Likes
Highlighted
Super Contributor.. d_shavrin Super Contributor..
Super Contributor..

Re: Failed to download server data (discoveryResources/ud_scanners/scanwin-x64.exe). No ZipEntry fou

is that the only error in error.log? Maybe there's an error about CP -1 around it, i recall it locked some download functionalities. It would be good to see the larget piece of the log file.

 

0 Likes
Super Contributor.. RRose Super Contributor..
Super Contributor..

Re: Failed to download server data (discoveryResources/ud_scanners/scanwin-x64.exe). No ZipEntry fou

Actually I believe this to be an environment issue rather than an application issue.  The update was successful on servers that were in the same domain as the application server.  If the probe was on a different domain that is when the error occurs.  Not sure what needs to be done to fix.  The probe server admin has opened the firewalls and security so I don't think that is the issue.  Perhaps a networking issue?

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.