Highlighted
Visitor.
2515 views

HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

HI Folks ,

 

As a long term road map to upgrade to HP UCMDB 10.X ,we wanted to bing our current set up from HP UCMDB 9.03 CUP 8 to HP UCMDB 9.05 with CUP 13 (I believe) we had diligently followed steps mentioned in Deployement guide the installtion went through sucessfully for HP UCMDB 9.05 Server and DAT Flow Probe Installation ,Post which we wanted to connect to connect to our exisiting old DB schemas ,but after lauching the CMDB Server Configuration Wizard to connect schemas we have got a strage error message Also no matter what if try to restart the UCMDB Server under Services MSC section of the OS it will start for say 2 minutes then fails again, i recollect this being common if yourdoing upgrade from 8.0x to 9.0x,having said after this error messages (attached screen shots ) I have verified the DB guide just to verify everthing was correctly configured seems to fine Follwed the instaruction from Page 38 to 40 in DB Admin Guide)

 

Could anyone please help us how to correct this error message attached in the screenshot .

 

Also please not we have configured any Integration Services yet in the environment and IIS is also not Configured in the same server

 

Thanks in Advance

 

Cheers

Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Final Verdict on this Issue

 

Rename the DB without - (hypen) in the Name solved the Mystery

 

Thanks a Lot for all valuable Feedback DIMA and Ashok

 

Cheers 🙂

View solution in original post

14 Replies
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution
Hello,

You can take a backup of Old logs and delete it and try to reconfigure the DB schema and rerun the services and then share the error.log file.
You can also verify the error.log in UCMDB Server.

Regards
Ashok
0 Likes
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Hi Ashok ,

 

Thanks a lot for Reply I Did check Error log File which i am have attahced in this Post it has very specific SQL Exception Error and I have Started working with my DB folks to examine cause as per this even DBupgrader package execeution Fails during Installation

 

Let me know if i have to take any further steps from My side

 

Thansk in Advance 🙂

 

 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution
Hi,

Yes, DB guys can help you better on this error.
Keep updated on the same.

Regards
Ashok
0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Hi,

I would like to confirm several details regarding upgrade performed.

Below is partial steps of Upgrade procedure from 9.0X to 9.05 from p117 of Deployment Guide. Please confirm that steps 3, 4 and 6 were done as explained. Please let us know what CP (Content Pack) version was on 9.03 before upgrade.

 

1. Stop the UCMDB 9.0x server before starting the 9.05 installation.

2. Run the UCMDB 9.05 installer for your operating system.

3. On the Select Installation Folder page of the installer, select the existing 9.0x installation folder.

4. On the Select Installation Type page of the installer, select Update from 9.0x. Note: The wizard checks that you have UCMDB version 9.0x already installed on your machine.

5. Complete the installation process.

6. The minimum supported HP Discovery and Integration Content Pack version for UCMDB 9.05 is Content Pack 7.00. If you have an earlier content pack installed, the latest content pack version (Content Pack 10) will be automatically installed. If you have Content Pack 7.00 or later installed, you are given the option of upgrading to Content Pack 10.

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

@Ashok Thanks Will Keep you Posted on the Update from DB folks

 

@Dima

 

Thanks again for Your reply 🙂 ,Yes I can confirm positively that all the Steps were performed diligently referring Deployment Guide and Also We had encoutered error while at last screen of wizard completion i am attaching the Screenshot for the same Version Details are mentioned Below .

 

HP uCMDB :9.03 CUP 6

 

 

0 Likes
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Hi Folks

 

Below is the latest Update from our investiigation .

 

The Below error is in Error Log attached prevously

 

Error message : [WrapperSimpleAppMain] (CmdbDalException.java:87) ERROR - Sql exception occured. Details:

Can't execute statement [ALTER DATABASE CMS-CMDB SET ALLOW_SNAPSHOT_ISOLATION ON], due to exception: java.sql.SQLException: [mercury][SQLServer JDBC Driver][SQLServer]Incorrect syntax near '-'.. The exceptions in the chain:

Cause (1): java.sql.SQLException: [mercury][SQLServer JDBC Driver][SQLServer]Incorrect syntax near '-'.

Stack trace (1):

java.sql.SQLException: [mercury][SQLServer JDBC Driver][SQLServer]Incorrect syntax near '-'.

 

DB Team Findings :they suggest that a [ ] is missing in the package script and SQL script should look like below .

 

Suggested SQL Query : ALTER DATABASE [CMS-CMDB] SET ALLOW_SNAPSHOT_ISOLATION ON (Attached screen for the same )

 

 

Could you please confirm

 

1.whether we manually perform the SQL script execution  post installation (with error though )?

 

Or

2. You guys suggest that we should correct the Script in the package file and re package it and then re install the Upgrade file --I Believe this would not be the case as no one had complained before for the sam package from HP site

 

Or Any further suggestion would be much appreciated .

 

Thanks in Advance 🙂

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Let your DBA perform the SQL. It should solve the problem.

ALTER DATABASE [CMS-CMDB] SET ALLOW_SNAPSHOT_ISOLATION ON;

 

 

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Hi Dima ,

 

I tried to Run the Script manually in SQL Client on a DB schemas both CMDB and History schemas, even after that if i try to connect to DB schemas it throws same Version Difference error ,So If carefully examine the HP UCMDB Server is now already upgraded to 9.05 and If try to re run the installation i cant do the Update from existing ,and i cant roll back as it works fine new DB schemas ,So literally eitherI have to do Follwoing to get to some kind of result

 

Step1 re install the 9.03

Step 2 run the SQL script first

Step 3 run the upgrade file for HP UCMDB Server

Step 4 Try to connect to old Schemas

 

Let me know if this would be the approach and correct me if i am Wrong

 

Thanks in Advance

 

Cheers 🙂

 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

I think correct approach would be:

1. Restore 9.03 DB from backup

2. Install 9.03 and connect to the DB

3. Don't uninstall 9.03 and start installation of 9.05 on top of it.

4. Choose Update from existing.

 

Please explain separately what do you mean by "run the upgrade file for HP UCMDB Server"? What exact action?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Hi Dima

 

Sorry My Bad

 

I meant the same action what you have mentioned "Re install the 9.05 on top of 9.03"

 

Thanks

0 Likes
Highlighted
Visitor.

Re: HP UCMDB Upgrade from 9.03 to 9.05 failed with error connecting to previous exisiting DB Schemas

Jump to solution

Hi Folks

 

Ok I have Rolled back the HP uCMDB app to 9.03 and Tried to Connect to Existing Schemas Works Just Fine .

 

Post this As i believed (instaed of thought) it would be better to run the script first and then try to run the Upgrade for 9.05 we did follow the proceddure and again we are at the same point where it all started it throws Version error again but works just fine if we connect to New DB Schemas

 

So I think I have No option further move ahead to Pre Prod Envirnment thinking its just one Odd Case of DEV experience

 

Now We are in Serious Thought process for UD 10.01 Deployement 😞 coz we dot want to perform a complete new installation we prefer upgrade Only as an Approach 😞

 

SO if you folks have any other suggestion please do suggest me

 

Thanks in advance

 

🙂

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.