Highlighted
New Member.
140 views

Import CSV File in UCMDB 10.01

Jump to solution

I'm on uCMDB 10.01 CUP 7.489 UD Content Pack 12.0.825 and I am trying to run the import CSV scenario that is outlined in the content help for the Import from CSV adapter.  Whenever I run the job it gets hung in a running state and never finishes.  This is what the communication log looks like:

 

<execution jobId="DS_Test Import_Import topology from CSV File" destinationid="fe88252ee6782c9336f51048510539b3" max_store_sent_results="2147483647">
    <destination>
        <destinationData name="id">fe88252ee6782c9336f51048510539b3</destinationData>
        <destinationData name="ip_address">170.11.193.87</destinationData>
        <destinationData name="hostId">5f932c4c542d4e29a138f7a899f2fd81</destinationData>
        <destinationData name="credentialsId">74_1_CMS</destinationData>
        <destinationData name="Protocol">ntcmd</destinationData>
        <destinationData name="connected_os_credentials_id">NA</destinationData>
    </destination>
    <protocol name="ntadmin" cm_credential_id="74_1_CMS">
        <object id="5b3a89d9368664896d0d16746699258a" id_type="CmdbObjectID" class="ntadminprotocol" isReference="false" is_anchor="false">
            <attribute name="ntadminprotocol_ntdomain" type="String">MMACCT</attribute>
            <attribute name="protocol_netaddress" type="String">DEFAULT</attribute>
            <attribute name="user_label" type="String">XXHPDisc</attribute>
            <attribute name="protocol_timeout" type="String">2000000</attribute>
            <attribute name="protocol_index" type="Integer">1</attribute>
            <attribute name="protocol_in_use" type="Boolean">false</attribute>
            <attribute name="cm_credential_id" type="String">74_1_CMS</attribute>
            <attribute name="protocol_username" type="String">XXHPDisc</attribute>
            <attribute name="protocol_type" type="String">ntadminprotocol</attribute>
        </object>
    </protocol>
    <params>
        <param param_name="csvFile" param_value="\\mmshpddmat1\E\csvimport\vehicles.csv" />
        <param param_name="defaultOwner" param_value="" />
        <param param_name="JOB_ID" param_value="DS_Test Import_Import topology from CSV File" />
        <param param_name="skipEmptyValues" param_value="" />
        <param param_name="delimiter" param_value="," />
        <param param_name="mappingFile" param_value="car_mapping.xml" />
        <param param_name="ciType" param_value="car" />
        <param param_name="flushObjects" param_value="false" />
        <param param_name="maxThreadRuntime" param_value="900000" />
        <param param_name="quoteSymbol" param_value="&quot;" />
        <param param_name="mappingString" param_value="0:car_name, 1:model, 2:year_of_manufacture, 3:date_of_purchase" />
        <param param_name="bulkSize" param_value="2000" />
        <param param_name="rowToStartIndex" param_value="0" />
    </params>
    <CONNECT start="10:01:37" duration="219" CMD="client_connect" RESULT="success" type="ntadmin" credentialsId="74_1_CMS">
        <ClientProperties>
            <prop name="protocol_timeout" value="2000000" />
            <prop name="trimWS" value="true" />
            <prop name="protocol_netaddress" value="DEFAULT" />
            <prop name="BandwidthLimit" value="0" />
            <prop name="credentialsId" value="74_1_CMS" />
            <prop name="protocol_type" value="ntadminprotocol" />
            <prop name="user_label" value="XXHPDisc" />
            <prop name="protocol_username" value="XXHPDisc" />
            <prop name="ntadminprotocol_ntdomain" value="MMACCT" />
            <prop name="protocol_in_use" value="false" />
            <prop name="cm_credential_id" value="74_1_CMS" />
            <prop name="protocol_index" value="1" />
        </ClientProperties>
    </CONNECT>
    <EXEC start="10:01:37" duration="78" CMD="ver" RESULT="Microsoft Windows [Version 6.1.7601]" />
    <log start="10:01:37" severity="debug">Windows ntcmd detected</log>
    <EXEC start="10:01:37" duration="63" CMD="ver" RESULT="Microsoft Windows [Version 6.1.7601]" />
    <EXEC start="10:01:37" duration="62" CMD="echo %ERRORLEVEL%" RESULT="0" />
    <log start="10:01:37" severity="debug">adding alternate cmd='wmic OS Get CodeSet &lt; %SystemRoot%\win.ini'</log>
    <log start="10:01:37" severity="debug">adding alternate cmd='%WINDIR%\system32\wbem\wmic OS Get CodeSet &lt; %SystemRoot%\win.ini'</log>
    <EXEC start="10:01:37" duration="94">
        <CMD>[CDATA&colon; wmic OS Get CodeSet &lt; %SystemRoot%\win.ini]</CMD>
        <RESULT>[CDATA&colon; CodeSet  
1252]</RESULT>
    </EXEC>
    <EXEC start="10:01:37" duration="63" CMD="echo %ERRORLEVEL%" RESULT="0" />
    <log start="10:01:37" severity="debug">command='wmic OS Get CodeSet &lt; %SystemRoot%\win.ini' ended successfully</log>
    <log start="10:01:37" severity="debug">adding alternate cmd='wmic OS Get OSLanguage &lt; %SystemRoot%\win.ini'</log>
    <log start="10:01:37" severity="debug">adding alternate cmd='%WINDIR%\system32\wbem\wmic OS Get OSLanguage &lt; %SystemRoot%\win.ini'</log>
    <EXEC start="10:01:37" duration="93">
        <CMD>[CDATA&colon; wmic OS Get OSLanguage &lt; %SystemRoot%\win.ini]</CMD>
        <RESULT>[CDATA&colon; OSLanguage  
1033]</RESULT>
    </EXEC>
    <EXEC start="10:01:37" duration="63" CMD="echo %ERRORLEVEL%" RESULT="0" />
    <log start="10:01:37" severity="debug">command='wmic OS Get OSLanguage &lt; %SystemRoot%\win.ini' ended successfully</log>
    <log start="10:01:37" severity="debug">Bundle postfix eng</log>
    <log start="10:01:37" severity="debug">Using charset: Cp1252</log>
    <log start="10:01:37" severity="debug">Can encode: True</log>
    <EXEC start="10:01:37" duration="0" CMD="setCharset" RESULT="windows-1252" />
    <EXEC start="10:01:38" duration="62">
        <CMD>[CDATA&colon; type "\\mmshpddmat1\E\csvimport\vehicles.csv"]</CMD>
        <RESULT>[CDATA&colon; Ferrari, GTSi, 1981, 05 MAY 2007 12:00
Volvo, P1800, 1962, 12 APR 2008 12:00
Ford, Gran Torino, 1975, 16 JUN 2005 12:00]</RESULT>
    </EXEC>
    <EXEC start="10:01:38" duration="63" CMD="echo %ERRORLEVEL%" RESULT="0" />
    <DISCONNECT start="10:01:38" duration="62" CMD="client_disconnect" RESULT="" IS_NULL="Y" type="ntadmin" credentialsId="74_1_CMS" />
</execution>

 

Anyone know why this job is not finishing?

0 Likes
1 Solution

Accepted Solutions
Highlighted
New Member.

Re: Import CSV File in UCMDB 10.01

Jump to solution
I think I have it figured out. I has something with the way I created the "Car" CI type.

View solution in original post

0 Likes
1 Reply
Highlighted
New Member.

Re: Import CSV File in UCMDB 10.01

Jump to solution
I think I have it figured out. I has something with the way I created the "Car" CI type.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.