Highlighted
Absent Member.. Absent Member..
Absent Member..
578 views

Job Template is not working

Jump to solution

HI,

 

I am working on UD 10.01

 

I have created zones of 5 to 6 IP ranges(total IPs 1000+) . Also applide  the tamplate containing  Host resources by shell , Host Resources by WIM  & IP ranges by ICMP job.

 

If I applied the template to the zone , It  discovers a single IP of DATA Flow Probe.   So created CI is 1 only.

 

 

So again I applied default job "Infrastructure" and acrtivated the same but this time it worked and discoved almost 800 ips with basic parameters.

 

I wonder , why this tamplate is not working with this zone but I tried the same tamplate for other single IP range of 30IPs. It worked and showed all Infrastructure  details/software/processes etc..

 

It is really strange and unable to figure out what is the issue.

 

Please help me as I am new to UD.

 

Thanks.

 

 

with regards,

Nick

 

 

 

 

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: Job Template is not working

Jump to solution

Dear Nick,

Please check attached screenshots. It contains jobs that should provide you with the data you're expecting to be discovered.

Teh general Flow is to create the template and then use the template for creation of new activity. During creation of activity you'll be able to set job parameters like "Discover CPUs".

Hope this helps.

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.

View solution in original post

0 Likes
6 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: Job Template is not working

Jump to solution

Templates is not what you need to run basic discovery. Infrastructure activity should cover your basic discovery needs.

Please be aware that UCMDB has following logicical flow in discovery:

IP -> Host Connection -> Host Resources -> all others discovery jobs.

Hope this helps.

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Job Template is not working

Jump to solution

Hi,

 

Thanks for the response.

 

 

I want to discover basic resources like ip,os, os user,interface, CPU, memory, Installed software, Running Software, etc.

 

This is possible through Host resource by Shell and Host resources by WMI job .

 

To apply these jobs on zones I had created template to activate the job on one zone  at a time. But same is not working.

 

 

The default infrastructure  job uses "Network connection by shell' adapter to discover the parameters anerd it doesnot even show CPU parameter and other softerware details(installed /running, processes)

 

 

Please suggest best possible way to discover all host resources and software parameters but want to activate one zone at a time.  Please tell me in which cases  the template can be used??

 

 

with regards,

Nick

 

 

 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: Job Template is not working

Jump to solution

What is a protocol you're planing to use for the discovery?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Job Template is not working

Jump to solution

HI,

 

Discovery is configured thrugh WMI and SSH only.

 

 

Thanks,

 

 

with regards,

Nick

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: Job Template is not working

Jump to solution

Dear Nick,

Please check attached screenshots. It contains jobs that should provide you with the data you're expecting to be discovered.

Teh general Flow is to create the template and then use the template for creation of new activity. During creation of activity you'll be able to set job parameters like "Discover CPUs".

Hope this helps.

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.

View solution in original post

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Job Template is not working

Jump to solution

Hi Dima,

 

Thanks for the solution.  It really helped me to troubleshoot exact problem.

 

The issue is reoslved now. As I was missing one connection job from template so it was not working as expected.

 

 

with regards,

Nick

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.