Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
263 views

Local client session expiration

I am using the local client with v2019.02.  After about 30 minutes the session locks with the message "Your session has expired".  It is not an inactivity timer, it seems to expire even if using the client.  Very annoying.  How do I change, or disable, this session timeout.

Thanks

0 Likes
6 Replies
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Hi,

Whats the local client version ? Have u tried the new local client 2019.05 ?

 

Thanks.

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

This is the local client which came with 2019.02.

Is the local client from 2019.05 compatible with 2019.02?

0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

I am using Local Client 2019.05 with my UCMDB 2018.08 and it works fine.

Highlighted
Micro Focus Expert
Micro Focus Expert

UCMDB Local Client is supported with everything higher than 10.22. Well, it actually works even with 10.1x but it's not supported for 10.1x.

There is also a 2019.08 version with a few minor changes.

Did you try to start from scratch with it? Maybe some left over files in %appdata% like described at the end of https://docs.microfocus.com/UCMDB/2018.05/ucmdb-docs/docs/eng/doc_lib/Content/admin/ucmdb_local_client.htm

Kind regards,
Bogdan Mureșan
EMEA CMS Technical Success
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Unfortunately switching to the 2019.05 local client did not make a difference.  I have also looked at the arguments passed on the java start command.  Nothing looks like a timeout value.

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

I believe that I have found the resolution to this issue.  The session expiration messages began after I activated SSA, which activates LWSSO.  There is an Infrastructure setting named "LWSSO cookie expiration" which is set to 30 minutes by default.  I changed this to 360 and I can now work for 6 hours before the session expires.

 

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.