Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Highlighted
Respected Contributor.. Ivan Kovac_1 Respected Contributor..
Respected Contributor..
52 views

Missing CI's in result of integration query

Hello,

I have problem with OOTB integration UCMDB 11.x and AM 9.70. I would use push job to transfer CI's to AM, however there are missing CI's in result of integration query, that is processed on probe side.

As example I can specify following situation. There are two vmware clusters in UCMDB with same name but configured in different vcenter, co containment in UCMDB is different and separate in UCMDB. I have prepared TQL in UCMDB that should push this two cluster CI's to AM (query is based on ootb AM Cluster Push 2.0).

When I invoked calculateTqlAdHoc method in JMX, result is following:

Mbean: UCMDB:service=TQL Services. Method: calculateTqlAdHoc

Calculation finished. Calculation time: 121 ms. Calculation result size: 2

Result:

ResultObjects:

Element Number = 11@2

{vmware_cluster@40dec7ff1e95827abdc28f2afb09b4e8}@[(string-vendor:v_mware_inc), (string-TenantOwner:TMCZ), (string-name:IIT_lin01), (string-global_id:40dec7ff1e95827abdc28f2afb09b4e8), (string-description:[Empty CMDB property value]), (string-root_class:vmware_cluster), (string-version:[Empty CMDB property value])] {vmware_cluster@4d4cc4aa9a73abb39cdc0b7efc600bb6}@[(string-vendor:v_mware_inc), (string-TenantOwner:TMCZ), (string-name:IIT_lin01), (string-global_id:4d4cc4aa9a73abb39cdc0b7efc600bb6), (string-description:[Empty CMDB property value]), (string-root_class:vmware_cluster), (string-version:[Empty CMDB property value])]

ResultLinks:

Version:PatternVersion:-9223372036854775808@ResultVersion:-9223372036854775808

 

However when I start push integration job, I can see that only one of those CI's is processed on probe side and in log I can see following statement:

2019-10-04 23:51:18,910  TRACE  [AdHoc:AD_HOC_TASK_PATTERN_ID-427-1570225879269] -  >> Received the following push CIs from UCMDB: com.hp.ucmdb.spi.data.replication.ReplicationLayoutResultActionDataImpl
Topology for update (size=0, reference=0):
CIs (0):
Relations (0):
Referenced CIs (0):
Referenced Relations (0):
Topology for add (size=1, reference=0):
CIs (1):
Node [11, type=cluster] CIs(1):
id=[AssetManagerRZT%0AamCluster%0A1%0AAM_PRIMARY_ID%3DINTEGER%3D21406488%0A] properties: [vendor=v_mware_inc[STRING], TenantOwner=TMCZ[STRING], name=IIT_lin01[STRING], global_id=40dec7ff1e95827abdc28f2afb09b4e8[STRING], description=null[STRING], root_class=vmware_cluster[STRING], version=null[STRING]]
Relations (0):
Referenced CIs (0):
Referenced Relations (0):
Topology for remove (size=0, reference=0):
CIs (0):
Relations (0):
Referenced CIs (0):
Referenced Relations (0):
 
 
I can't find any information what is class com.hp.ucmdb.spi.data.replication.ReplicationLayoutResultActionDataImpl and why only one CI is received as result from UCMDB.
 
Thanks for any help.
Regards
Ivan
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.