Highlighted
Super Contributor.
Super Contributor.
210 views

NetApp Filer discoveries

Hello Experts,

We are facing issues with NetApp Filer discoveries and HP support has suggested an ER for this kind of discovery. However, we find the old ER has been deffered. (

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR1H99512)

The filer is FAS6290 and yes it’s on cluster ontap 8.3.1P2 version. The UCMDB version we are using is 10.21.

We find the script referencing to old commands like (system-get-info) which is not available in NEtApp SDK as well.

Please let us know the best way to get the NEtApp Filers discovered.

 

Regards

Binu

 

0 Likes
5 Replies
Highlighted
Trusted Contributor.
Trusted Contributor.

Re: NetApp Filer discoveries

Hello,

Hope you are more than great. 

Please follow the next link: https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR1H101981 .

Please let me know if you have any doubt.

Regards

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: NetApp Filer discoveries

Hi Team,

We had a long 3 hour of webex session with NetApp team on the Filers discovery. All access has been granted and our discovery is able to discover the version of NetApp 1.31.

However it always fails at "System-get-info" when running the NEtApp filer by webservice jobs, and we have been validating the NetApp SDks version 5.3.1 and SDK 5.4 API's.

Has anyone discovered NetApp filer before? (HP Case# 5308583771)

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: NetApp Filer discoveries

BTW this is on a cluster

The filer is FAS6290 and yes it’s on cluster ontap 8.3.1P2 version. How do we make the discoveries successfull?

 

0 Likes
Highlighted
Trusted Contributor.. Trusted Contributor..
Trusted Contributor..

Re: NetApp Filer discoveries

Hi ,

by checking the script, UD is using NA and system-get-info API .

## Get HOST details

       hostInfoRequestElement = NaElement('system-get-info')

       hostInfoResponseElement = netapp_webservice_utils.wsInvoke(wsConnection, hostInfoRequestElement)

 

I have heard that there is a lot changes happening in cluster 8.3 from 7.x .The big change it's NC instead of NA (get-na vs get-nc).

Have you checked with NetAPP team that your system supports NA and system-get-info API ?

Regards,

Erika

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: NetApp Filer discoveries

Hi Erika,

Yes, we had the same discussion and it looks like the APIs in the new versions are causing the issue. Will it work if we change to NC instead of NA? NetApp support team says yes it might work but it is on our end to change the code accordingly.

Do you have any sample scripts which we can use to test? We are referrencing the APIs and manually trying the change of code by adding debuuger logs after each output and is kind of tedious. Any help is highly appreciated.

Regards

 

 

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.