Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Absent Member.. hansonck Absent Member..
Absent Member..
1236 views

Rule name is not valid. Enter a valid rule name.

Jump to solution

Having an issue where we cannot create any new enrichment rules because of an error. The error message we receive is "Rule name is not valid. Enter a valid rule name." We receive this error from the New Enrichment Rule dialog box on the Rule General Attributes page (1st page). Normally the message comes up before you enter a valid name into the Rule Name text box and goes away once the user types a valid name but in this case the message stays there regardless of what is typed.

 

The Back, Next and Finish buttons are greyed out in the dialog box even after the user types a valid name, preventing any new enrichment rules from being created.

 

UCMDB version is 10.20.480, CP 15.01.143

 

Any suggestions would be appreciated, thanks.

0 Likes
1 Solution

Accepted Solutions
Absent Member.. hansonck Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

@ral8667,

 

I can see the discussion topic in the search results of the self-solve portal but I can't get to it--so no help for either of us there, sorry.

 

I have figured out a workaround. First a little context...

In the environment where the original screenshot was taken I checked the "Do not show this page again" check box on the "Welcome" page of the New Enrichment Rule wizard. This was done back when the environment was on version 10.11 and after the upgrade to 10.20 I could no longer get the error/warning to go away and could no longer make enrichments. Notice in the screenshot the Steps column starts with "Rule General Attributes", not "Welcome"

 

Accessing another environment (same version, CUP and CP) where I didn't check that box I see the "Welcome" page, and after clicking "Next" and entering a string into the "Rule Name" text box, I receive the exact same error, which also won't go away. However, once I click the "Back" button, go back to the Welcome page and click "Next" again, the name I typed into the "Rule Name" text box is still there but the error/warning is gone and I can make my enrichment! (note in the screenshot I attached here the Welcome step is still in the Steps column of the wizard).

 

So, as long as you do not check the "Do not show this page again" checkbox on the Welcome page of the wizard you should be able to use the Back button as a workaound. If you've already checked that box you will have to figure out how to restore your user preferences to default (if you accomplish this, tell me how) or delete/recreate your user to reset the preferences?

8 Replies
Highlighted
Absent Member.. Sree_CMS Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

Name is a key word. You will not be able to use generic keywords..

 

Try to give a valid name for the enrichment based on your use case Ex: Enrich_Customername_Attribute.. 

0 Likes
Absent Member.. hansonck Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

Thanks for the reply, however the string "Name" in the screenshot was just a placeholder for ANY text string typed into the text box. Like I wrote in the post, it doesn't matter WHAT is typed into the box, the warning/error message never goes away. I suppose that is my fault for putting that particular string into the box for the screenshot example, I didn't think anyone would take that literally!

 

Note: I have removed the original screenshot so that it would not be a further distraction and have attached another screenshot to this post w/ completely different strings but the same exact outcome.

 

I should also add that the problem occurs across multiple users, multiple JRE versions and in IE, chrome and Firefox so I don't believe it is a problem w/ the client(s).

0 Likes
Absent Member.. ral8667 Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

I'm have the EXACT same issue.  I just applied CUP1 for 10.20, but that didn't fix my issue.  I have a case open, but no luck there yet.  Enrichment rules were working just fine with 10.20, then this issue started.

 

On another forum, there was mention of QCCR1H37578 which I believe has to do with enrichment rules.  But I don't know the details.

 

 

0 Likes
Absent Member.. Sree_CMS Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

It works fine with 10.20.480. I was able to create and run enrichments. 

0 Likes
Absent Member.. hansonck Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

@ral8667,

 

I can see the discussion topic in the search results of the self-solve portal but I can't get to it--so no help for either of us there, sorry.

 

I have figured out a workaround. First a little context...

In the environment where the original screenshot was taken I checked the "Do not show this page again" check box on the "Welcome" page of the New Enrichment Rule wizard. This was done back when the environment was on version 10.11 and after the upgrade to 10.20 I could no longer get the error/warning to go away and could no longer make enrichments. Notice in the screenshot the Steps column starts with "Rule General Attributes", not "Welcome"

 

Accessing another environment (same version, CUP and CP) where I didn't check that box I see the "Welcome" page, and after clicking "Next" and entering a string into the "Rule Name" text box, I receive the exact same error, which also won't go away. However, once I click the "Back" button, go back to the Welcome page and click "Next" again, the name I typed into the "Rule Name" text box is still there but the error/warning is gone and I can make my enrichment! (note in the screenshot I attached here the Welcome step is still in the Steps column of the wizard).

 

So, as long as you do not check the "Do not show this page again" checkbox on the Welcome page of the wizard you should be able to use the Back button as a workaound. If you've already checked that box you will have to figure out how to restore your user preferences to default (if you accomplish this, tell me how) or delete/recreate your user to reset the preferences?

Absent Member.. ral8667 Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

Just to clarify my previous post, I'm using a fresh installation of 10.20.  I was able to create enrichment rules with no issues.  Then all of a sudden I couldn't.  When CUP1 came out, I applied it to see if it would help, but it didn't.

 

Regarding your work around, I had already checked the box "do not show this page again" while logged on with my primary user account.  So I simply created another user with rights to create enrichment rules.  I confirmed I can create a new enrichment again using your steps.  I appreciate the solution until HP can resolve this.

 

Thanks!

 

0 Likes
Absent Member.. ral8667 Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

If you want to be able to get the welcome screen back in the Enrichment Rules page for any user, logon as that user, then click the Tools menu followed by User Preference.  There is a setting called "Enrichment Rule Properties - show welcome page", but I couldn't make that setting bring back the welcome page.  So I clicked the "Reset All" button at the bottom, and now I have the welcome page back when creating Enrichment Rules.

 

Thanks.

Absent Member.. hansonck Absent Member..
Absent Member..

Re: Rule name is not valid. Enter a valid rule name.

Jump to solution

Thanks for closing the loop on the preferences reset!

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.