Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
90 views

Scanfile is not showing correctly in ucmdb

I have a scanfile that shows the installed software I am looking for on a laptop but it is not being processed correctly and the data is not making it to the ucmdb. I have moved the scanfile from processed folder back to incoming to see if it would push over to the ucmdb but it is still not showing the correct information. What else can I do to get the correct information into the ucmdb? Any troubleshooting steps?

0 Likes
4 Replies
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Scanfile is not showing correctly in ucmdb

Where did you find the installed software as discovered? Best way to see what is sent is to run the job in debugging and recording the results mode. This is done when you click on the trigger CI -> Debug -Rerun -> Enable comm log and record results.

Once you have the communication log, you will see what CIs are submitted to UCMDB. if installed software is not one of them, then you need to change the scanner config definition and check what is written in the "Mapping Configuration" section of the inventory job.

 

Regards,

Petko

Likes are appreciated!
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Scanfile is not showing correctly in ucmdb

Use the Viewer application, part of the Inventory Tools installation, to view the scan file in question. Take a look at the software application tab and see whether the missing applications are full or partial recognition.
Scan_File_Viewer_partial_recognition.png

If the applications are only partial recognition I suggest you update your Inventory Discovery Knowledge Pack to try and get them up to full recognition. If you really need these partial recognition, this is because the main file is not identified and identified software could be newer then available recognition rules or wrong identification entirely, then you can add partial recognition to the mapping configuration in the Inventory Discovery by Scanner properties.
Mapping_Configuration_partial_recognition.png

I don't recommend this option, instead you should work to get full recognition either by updating SAI rules or adding your own rule in a user.zsai file.

John

Tags (2)
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: Scanfile is not showing correctly in ucmdb

All the software is fully recognized. I have over 100 software titles but in the ucmdb ui I am only showing 16 for that laptop.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: Scanfile is not showing correctly in ucmdb

Without showing the scan file, we have to just guest where do you see the 100 softwares. It is highly unlikely to have 100 fully recognized entries (as from the screenshot of @John Goldstein ) and provision only 16 of them in UCMDB. Send similar screenshots of where do you see 100 and where 16. Plus have you seen the communication log and recorded results. 

Likes are appreciated!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.