Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..
2644 views

UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

Im trying to setup integration point between UCMDB 10.01 and Asset Manager 9.30 using AM Data push Adapter.

 

I got the attached error when I tried to test the connection of the integration point.

 

I can setup a integration point between the two server using the AM Population and Federation Adapter just fine. But with the AM Data Push Adapter  i cant even get past the test connection window.

 

The only other error I see is in the probe_error.log

 

<2013-03-19 18:38:07,229> [ERROR] [AdHoc:AD_HOC_TASK_PATTERN_ID-103-1363736297256] (FederationNoneLifeCycleProbeProcessor.java:72) - Failed executing none life cycle federation request [com.hp.ucmdb.discovery.probe.request.TestConnectionProbeRequest] for integration [Asset]
Test ConnectionFailed

 

Not alot of information. Anyone encounter this problem before?

 

Thank

0 Likes
1 Solution

Accepted Solutions
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

your right it the ssl thingy 🙂

 

The probe server was missing the  Microsoft Visual C++ 2008 Redistributable Package (x64). Once I installed the package and restart the probe. It connect!!!!!!!!!

 

 

View solution in original post

8 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

Any thought on what I should check?

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

According to provided logs:

Connection failed. Please check the 
parameters and/or the description stored in the "amdb.ini" file.

 

 

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

The reason i was getting that message was because i miss one of the .dll...now im getting a different error...

 

The error point to incorrect user name...I tried with a couple different account and still got the same error. Test the login of those account through web and win32 client and it work. So Im pretty sure the login are correct.

 

The libeay64.dll is copied over to DFP folder already 

 

Caused by: com.peregrine.ac.AmException: Error (12,001): Module 'Ssl' : Unable to load dynamic
library (libeay64.dll)'
Unable to initialize SSL library.
The user name or password is
incorrect

at com.peregrine.ac.api.AmApi93JNI.AmGetConnection(Native Method)
at com.peregrine.ac.api.AmApi93.AmGetConnection(AmApi93.java:93)
at com.peregrine.ac.api.AmApi.getConnection(AmApi.java:91)
at com.peregrine.ac.api.AmApi.startTransaction(AmApi.java:807)
... 37 more
--- End of probe-side exception ---

 

 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

Please check connection from the probe machine. It could be restriction for specific hosts.

As additional suggestion, I'd ask you to recreate specific credential in UCMDB.

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

I can access the Asset Manager using the web client and i do a trusted share with Asset Manager. 

 

I can also successfulyl connect with Asset Manager using Population and Federation Adapter for UCMDB 10.01.

 

It just this Data Push adapter that is giving me error. 

 

I delete the integration point and credential and remake both. Still getting the same error

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

This is SSL related thingy.

Which ca-store contains SSL certificates used with Population and Federation Adapter for UCMDB 10.01?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
Tags (1)
0 Likes
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

your right it the ssl thingy 🙂

 

The probe server was missing the  Microsoft Visual C++ 2008 Redistributable Package (x64). Once I installed the package and restart the probe. It connect!!!!!!!!!

 

 

View solution in original post

Highlighted
Super Contributor.
Super Contributor.

Re: UCMDB 10 Asset Manager Data Push Adapter

Jump to solution

HI ctruong,

THanks for the post. i got the same error which got fixed after installing the Microsoft Visual C++ 2008 Redistributable Package (x64) in UD Probe server.

THank you very much 🙂

Thanks & Regards
Govind Bisht
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.