Highlighted
Micro Focus Expert
Micro Focus Expert
210 views

(UCMDB) Support Tip - After upgrading to Content Pack 24, UD Agent creates a "Program" folder

Error Message

(Windows only) After installing UCMDB 10.33 and CP24, or after upgrading to Content Pack 24, the "C:\Program" folder is found on the inventoried machines.

Cause

The root cause is that while running scanner on Windows platform, the following command will be executed:

mkdir C:\Program Files (x86)\Hewlett-Packard\Discovery Agent\

The path is not surrounded with quotation marks "", which causes the issue.

Workaround / Fix

The fix is to add quotation marks "" around the directory while executing the mkdir commands.

To do so, do the following:

Download the FixProgramFolder.zip. 

In UCMDB UI, go to Data Flow Management > Adapter Management, search for and backup the following files:

ScannersConfigurationByPlatform.xml

InventoryUtils.py

Go to Administration > Package Manager, click Deploy packages

   

Reference: https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM02940732

MICRO FOCUS Software Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please hit the Kudo botton, if you find this post useful.
Labels (1)
Tags (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.