Highlighted
Micro Focus Expert
Micro Focus Expert
508 views

(UCMDB) Support Tip - Connection via PowerShell fails

In the event of attempting to perform discovery via PowerShell adapter. Have enabled PowerShell on the remote host as described in the content help (manual connect via command line is working fine), supplied the correct credentials but connection fails with following error in “probeMgr-adaptersDebug” log file of the probe:

… [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Starting script entity.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Finished script entity.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Starting script protocol.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Finished script protocol.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Starting script check_credential.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Finished script check_credential.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Starting script powershell_check_credential.py <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Trying to connect to ip=192.168.40.1 by 'powershellprotocol' protocol ... <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Process exited with non-zero exit code [-2146232576], logging output... <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Process output stream is empty <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Process error stream is empty <…> [DEBUG] [JobExecuterWorker-2:adhhocJob_powershell_check_credential_...] - Connection to … by 'powershellprotocol' failed Traceback (most recent call last): File "check_credential", line 46, in connect File "fptools", line 159, in __call__ File "check_credential", line 88, in _genericConnect Exception: java.lang.Exception: Failed to establish PowerShell session.

Having the mentioned *.py scripts, not being able to identify the issue.

In this case the server where the probe is installed runs Win2012R2, which comes with PowerShell 4.0.

Documentation states that discovery only uses PS 2.0.

As a workaround, if one refer to KB article from Microsoft to install PS2.0 engine together with 4.0 discovery will run fine after restarting the probe. https://technet.microsoft.com/de-de/library/hh849675.aspx

MICRO FOCUS Software Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please hit the Kudo botton, if you find this post useful.
Labels (1)
Tags (1)
0 Likes
2 Replies
Highlighted
Visitor.

Re: (UCMDB) Support Tip - Connection via PowerShell fails

Sorry , but supplied link is no longer valid.

0 Likes
Highlighted
Frequent Contributor.. Frequent Contributor..
Frequent Contributor..

Re: (UCMDB) Support Tip - Connection via PowerShell fails

both windows PowerShell 4 and 2 was installed and under WinRM client, trust host option was enabled and added * to indicate all remote host are trusted.

I was able to establish the connection successfully with PowerShell and PowerCmd protocol credentials from UCMDB UI.

thanks

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.