Highlighted
Micro Focus Expert
Micro Focus Expert
565 views

(UCMDB) Support Tip Host connection by powershell job fails with Invalid username / password message

If encountered the following error in communication log file when running Host connection by powershell job:

****

<ERROR class="com.hp.ucmdb.discovery.library.clients.AuthenticationException"> <message>[CDATA: Failed to authenticate with provided credentials]</message> … <log start="18:20:13" severity="debug">powershell: Invalid user name or password</log> <log start="18:20:13" severity="debug">Reporting error code 302 to framework.</log> <log start="18:20:13" severity="debug">Error message is: powershell: Invalid user name or password</log>

****

Powershell connection from the probe with the same credentials and target FQDN works properly outside of UCMDB.

The following command based on UCMDB binary also works: PowerShellConnector.exe -d FQDN -u <username>.

Response

  • The problem in this concrete scenario was outside of UCMDB.
  • The network DNS stuff did not have co-relation between FQDN and IP: “nslookup FQDN” and powershellconnector connection using FQDN was working ok, while “nslookup IP” and powershellconnector using IP was not working.
  • The discovery started to work as expected with the network issue fixed by the network administrator.

 

Reference: https://softwaresupport.hpe.com/km/KM02786104

MICRO FOCUS Software Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please hit the Kudo botton, if you find this post useful.
Labels (1)
Tags (1)
0 Likes
3 Replies
Highlighted
Visitor..
Visitor..

Re: (UCMDB) Support Tip Host connection by powershell job fails with Invalid username / password mes

can you please explain what the network fix was?

We are getting this error when attempting a powershellconnector command from our probe to the host:

D:\>hp\UCMDB\DataFlowProbe\runtime\probeManager\discoveryResources\PowerShellCon
nector.exe -d x.x.x.x -u (serviceaccount)
Enter password:
Connecting to x.x.x.x

Connecting to remote server failed with the following error message : The WinRM
client cannot process the request. Default authentication may be used with an IP
 address under the following conditions: the transport is HTTPS or the destinati
on is in the TrustedHosts list, and explicit credentials are provided. Use winrm
.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list mig
ht not be authenticated. For more information on how to set TrustedHosts run the
 following command: winrm help config. For more information, see the about_Remot
e_Troubleshooting Help topic.
System.Management.Automation.Remoting.PSRemotingTransportException: Connecting t
o remote server failed with the following error message : The WinRM client canno
t process the request. Default authentication may be used with an IP address und
er the following conditions: the transport is HTTPS or the destination is in the
 TrustedHosts list, and explicit credentials are provided. Use winrm.cmd to conf
igure TrustedHosts. Note that computers in the TrustedHosts list might not be au
thenticated. For more information on how to set TrustedHosts run the following c
ommand: winrm help config. For more information, see the about_Remote_Troublesho
oting Help topic.
   at PowerShellConnector.PowerShellWrapper..ctor(String host, Int32 port, Strin
g username, String password, String sessionIdentifier, Boolean useSSL, String ap
plicationName, String connectionUri, Boolean allowRedirect)

Connection failed.

 

We added the probe to the TrustedHosts and still get a failed connection.

 

0 Likes
Highlighted
Respected Contributor.. Respected Contributor..
Respected Contributor..

Re: (UCMDB) Support Tip Host connection by powershell job fails with Invalid username / password mes

Hi Spiceyal,

Were you able to resolve your issue?

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: (UCMDB) Support Tip Host connection by powershell job fails with Invalid username / password mes

Hello,

Each environment is unique and there could be other factors that can be causing such issues. It will be best to open a Support ticket to have us take a look at the issue in more depth.

Thanks,

MICRO FOCUS Software Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.
Please hit the Kudo botton, if you find this post useful.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.