Highlighted
Absent Member.. Absent Member..
Absent Member..
235 views

UCMDB Support Tip: What to do when UCMDB User Interface takes a long time to load.

If ever ran into a case where UCMDB User Interface would be slow to change from IT Universe to Modeling Studio.  Examining the system, the following from the JMX Console is observed:

 

 

In order to resolve such discrepancy, it is recommended the setting: mam.gui.automation.flow.mapping.enabled is set to false.  This will only impact the OO integration.  Once this is changed, the GUI will load much faster.

"HP Support
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution."

Click the KUDOS star on the left to say 'Thanks'
Labels (1)
Tags (1)
3 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: UCMDB Support Tip: What to do when UCMDB User Interface takes a long time to load.

I'd like to point your attention, that inaccurate LDAP integration could be another source of slowness.

Integration with LDAP has two flows

1. Authentication - to check that password is correct

2. Authorization - actually mapping of specific LDAP group/user to specific role in UCMDB. 

In the second flow, in case the filter in LDAP configuration is returning all users in organization, the sync of thousand records will take loooong time. Please note, that this will happen on every login. 

 

As a best practice, I'd like to recommend creation of at least two separate groups on LDAP - one for users and another one for admins.

Hope this helps

 

 

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: UCMDB Support Tip: What to do when UCMDB User Interface takes a long time to load.

Hi


Please Let me know where i can find mam.gui ......... setting in jmx . I tried but not found in jmx



With Regards,
Nick
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: UCMDB Support Tip: What to do when UCMDB User Interface takes a long time to load.

Hi Nick,

 

You can set that under Administration > Infrastucture Settings Manager > Enable Automation Flow Mapping.

(ID - mam.gui.automation.flow.mapping.enabled)

 

Regards,

Unni

“Micro Focus Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

Click the KUDOS star to say 'Thanks'
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.