Highlighted
Super Contributor.
Super Contributor.
883 views

Unable to Log Into uCMDB

I'm not able to log into uCMDB.  I enter my user name and password at the prompt and I receive no error message but I'm returned to the log in page to enter my user login and password again.  In the error log file on the uCMDB server I see this message:

2017-02-23 09:36:41,571 WARN [qtp1466962626-37697] (Log4JLogger.java:449) - [SECURITY FAILURE Anonymous:null@unknown -> /ExampleApplication/IntrusionDetector] Invalid input: context=password, type(SafeString)=^[\p{L}\p{Digit},\\:/. _?&%=+-\[\]\(\)\|\"]*$, input=(my password was showing up here but I removed it)
org.owasp.esapi.errors.ValidationException: password: Invalid input. Please conform to regex ^[\p{L}\p{Digit},\\:/. _?&%=+-\[\]\(\)\|\"]*$ with a maximum length of 1024

I was able to login yesterday.  I've tried to log in from a different computer with the same result. Another user is able to log in without issues.

Any suggestions as to what could be happening here and how it can be resolved.

0 Likes
9 Replies
Highlighted
Visitor.

Re: Unable to Log Into uCMDB

Hello,

Did you recently change your password? It seems that there are some unsupported characters inside it, as mentioned by the exception message. What is supported:

  • letters
  • digits
  • ,\:/. _?&%=+-[]()|" and space characters

Please check you password for all characters which don't fit the above pattern. You can control what characters are supported by editing this regex inside the <UCMDB_installation_folder>\conf\esapi\ESAPI_validation.properties file.

Regards,

Radu

0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Unable to Log Into uCMDB

There isn't a file or folder in the location you mention.  I did change my password last week and that's when it started happening.  I changed my password again and it's still not working.  My password does have the "$" in it.  But I have an admin account that has the "@" character in it and that seems to be working today.

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: Unable to Log Into uCMDB

What version of UCMDB you are on?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: Unable to Log Into uCMDB

10.20.480

0 Likes
Highlighted
Visitor.

Re: Unable to Log Into uCMDB

Ah, for 10.20, the location for those files is: <UCMDB Server Install>\deploy\ucmdb-ui\WEB-INF\conf

Try to add your extra characters there.

Highlighted
Super Contributor.
Super Contributor.

Re: Unable to Log Into uCMDB

If the setting in uCMDB is set to false for "Passwords must use default policy", wouldn't this mean that it's not enforcing this?  I changed that to false last week.  It seems strange that my admin account password contains a character that isn't in the validation file, yet I'm able to log in without any issues using that account.  All previous password changes for my regular account seemed to be fine and they all contained at least one special character like @, $, ! because our password policy for our AD accounts is pretty strict where we need to have at least 14 characters with a combination of upper case, lower case, numbers and we can have special characters there.

I feel like there's something else happening here where it's not allowing me to log in with my regular account.  I'll try to change my password again and not use any special characters and see what happens.

 

0 Likes
Highlighted
Visitor.

Re: Unable to Log Into uCMDB

The valid characters for any input in the UCMDB (as defined in the ESAPI_validation.properties) is a security feature and it cannot be turned off. The setting you're mentioning is for using a "OOTB default password" for newly created users. All new users will need to change their password when they try to login the first time.

 

0 Likes
Highlighted
Contributor.. Contributor..
Contributor..

Re: Unable to Log Into uCMDB

I tried changing this file but the changes didn't take effect. Does this require restarting the UCMB Server service?

0 Likes
Highlighted
Valued Contributor.. Valued Contributor..
Valued Contributor..

Re: Unable to Log Into uCMDB

Hi,
We have the same problem.
We tried ESAPI_validation.properties file in the conf folder, but didn't work. However We didn't restart the UCMDB Server service so should restart it?

Please update this topic.

Thanks,
Burak.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.