Highlighted
Absent Member.
Absent Member.
443 views

Unable to open custom made CI

Dear Experts,

I am currently using UCMDB 10.01 and the version of my probe is 10.01 CUP 2.145

I recently pushed the MYSQL data into UCMDB.

First tested it in the testing environment and it seemed to work fine.

Now I tried pushing the data to the production environment and tried to repeat the exact steps that I did to push the data to the testing environment.

 

After pushing some of the data into the production environment, the CIs seem to be populating as there are 3 different CIs populating(A ,B , C). We edited in "CIT Manager" so that 'A' has a 'containment' relationship with 'B' and 'C'.

However, CI 'A"  was unable to get Element Instances. When I tried to get Element Instances, it says "unexpected error"

 

So I tried to get "related CIs"  for some of the other CIs that was pushed into UCMDB. 

I tried to see if I can use "get related CIs" to see how CI 'B' was connected to CI 'A'

 

then I get this error message:

 

 Invocation of method [public abstract

com.hp.ucmdb.ui.ui_backend.model.foldertopology.UIFoldedTopology

com.hp.ucmdb.uiserver.services.cmdb.RelatedCIsService.getRelatedTopology(com.

hp.ucmdb.ui.ui_backend.model.itu.RelatedCIsQuery,com.hp.ucmdb.ui.shared.model.r

equest.RequestId)]

failed in HTTP invoker remote service at

[http://honts7821e:8080/ucmdb-ui/services/RelatedCIsService]; nested exception is

java.lang.RuntimeException: Error while invoking service.

(RelatedCIsService#getRelatedTopology)

Server Exception:

Class "Store" is not defined in the uCMDB 

class model

 

Any advice is very much appreciated.

Thanks,

 

 

 

P.S. This thread has been moved from Application Perf Mgmt (BAC / BSM) Support and News Forum to CMS and Discovery Support and News Forum. - Hp Forum Moderator

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.