Highlighted
Absent Member.. Absent Member..
Absent Member..
305 views

Update failed for Dept Table in SM from UCMDB

Hi,

 

I am trying to integrate UCMDB 10.01 with SM9.

I am trying to populate "Department" table in SM using the OOB "ucmdbDept" WSDL from UCMDB.

It runs successfully and pushes the CI only for the first run(Creation), After the first run, every time we run the integration Job, it fails with the following error:

  <cmn:message type="String">The record being added contains a duplicate key (se.base.method,add.record.radd)</cmn:message>
        <cmn:message type="String">This record contains an invalid duplicate key.</cmn:message>

 

Looks like it tries to create the CI every time in SM. Can you please give some suggesitons if i went wrong somewhere.

 

Regards

Ashok

 

0 Likes
1 Reply
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Update failed for Dept Table in SM from UCMDB

Hi,
Also, what i have observed from the SM.log file is it every time gets the Insert request from UCMDB.
Createrequest only goes to SM Department table always eventhough the record is already existing in SM.
In my SMSyncConffile all the three requests are available(Create, Update and Delete webservice request).

Regards
Ashok
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.