Highlighted
Absent Member.. Absent Member..
Absent Member..
398 views

Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution

Hello,

 

I just ran the uCMDB 10.20 upgrade and it fails in the proces.

The server status site, section Detailed Status lists a lot of components with status up but:

 

topology-search Failed

 

In the D:\hp\UCMDB\UCMDBServer\runtime\log\servicepack.install.log

the following line repeats over and over: (only thing changing is the time of course)

 

2015-04-30 14:12:41,578  INFO   [Starter for "topology-search" (during Writer server startup). (customer 1, id name: Default Client)] - No blacklist item contained spaces

 

A restart of the service and server did not change anything, the servicepack.install.log still repeats the same line.

 

It looks a lot like this topic:

http://h30499.www3.hp.com/t5/uCMDB-Support-Customer-Forum/After-upgrading-from-ucmdb-10-00-to-10-01-the-appserver-doesn-t/m-p/6267769#M1069

 

But there is no answer supplied 😞

 

Any suggestions to resolve this issue would really be appreciated!

 

Best regards,

Jaco de Weerd

Tags (3)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution

Workaround suggested by HP support did the trick:

 

The regional settings standard for our environments is dutch in wich the decimal separator is a , (comma)

For the service account which runs the UCMDB service, the decimal separator is set to a . (dot)

Now the installation continues.

 

We have seen more problems with the decimal  separator, also with the system health disk space monitors.

 

Nice to have a workaround, but weird that this was working in previous versions.

View solution in original post

0 Likes
5 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution

Hello Jaco ,

 

We hope you are doing well .

 

Thanks for share with us your interesting question .

 

Fistly , Would you please send us the next files : 

error.log , wrapper.log , startup.log 

 

Best Regards ,

Melissa Carranza Mejias
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation. “
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution
Hi Melissa,

Thank you for your message. This week I am out of the office. I have also created case 4651298368. My colleagues are currently updating this case. If you are interested you can probably access the logs from that case? Otherwise I hope it will be solved and I will also update the outcome of the case here.

Best regards,

Jaco
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution

The Case is still open, no solution yet.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution

Updates so far:

 

Running the following JMX methods and restarting  the UCMDB server did not provide a solution
UCMDB:service=Topology Search Services::Reindex  (failed)
UCMDB:service=DAL services::rebuildModelDBSchemaAndViews  (failed)
UCMDB:service=History DB Services::alignHistoryForType  (succeeded)

In error and startup log there is a specific error that suggests where the issue could be. Except the black list items there is an issue with the Solr search engine:

2015-05-20 15:03:10,889 ERROR [Starter for "topology-search" (during Writer server startup). (customer 1, id name: Default Client)] - Failed to start component [topology-search]
java.lang.NoClassDefFoundError: Could not initialize class com.hp.ucmdb.search.connection.SolrGlobalConnectionManager
at com.hp.ucmdb.search.connection.SolrConnectionFactory.acquire(SolrConnectionFactory.java:15)
at com.hp.ucmdb.search.connection.SolrConnectionFactory.acquire(SolrConnectionFactory.java:6)
at com.hp.ucmdb.search.CmdbSearch.getSearchEngineConnection(CmdbSearch.java:705)
at com.hp.ucmdb.search.CmdbSearch.initConnectionFactory(CmdbSearch.java:118)
at com.hp.ucmdb.search.CmdbSearch.(CmdbSearch.java:84)
at com.hp.ucmdb.search.manager.SearchManagerImpl.startUp(SearchManagerImpl.java:97)
at com.mercury.topaz.cmdb.server.manage.service.impl.ServiceComponentImpl.startup(ServiceComponentImpl.java:118)
at com.mercury.topaz.cmdb.server.manage.service.impl.ServiceComponentImpl.startupSubsystemManagers(ServiceComponentImpl.java:108)
at com.mercury.topaz.cmdb.server.manage.service.impl.ServiceComponentImpl.startUp(ServiceComponentImpl.java:70)
at com.mercury.topaz.cmdb.server.manage.instance.CustomerInstanceImpl.startComponentLocally(CustomerInstanceImpl.java:104)
at com.mercury.topaz.cmdb.server.manage.instance.CustomerInstanceImpl.startComponentLocally(CustomerInstanceImpl.java:94)
at com.mercury.topaz.cmdb.server.manage.instance.Controller$ComponentLifecycleImpl.startComponent(Controller.java:291)
at com.mercury.topaz.cmdb.server.manage.instance.CustomerController.startComponent(CustomerController.java:482)
at com.mercury.topaz.cmdb.server.manage.instance.CustomerController.access$200(CustomerController.java:29)
at com.mercury.topaz.cmdb.server.manage.instance.CustomerController$RunnerWrapper.run(CustomerController.java:444)
at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:599)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:534)
at java.lang.Thread.run(Thread.java:722)

Running JMX mthod> UCMDB:service=Settings Services > setSettingValue.
In the name field enter: cmdb.search.enabled.  (including trailing dot)
In the value field enter: true: If you want the search enabled. false: If you want the search disabled.
Click Invoke.
Restart the UCMDB server -> Did not provide a solution yet.

To be continued.

 

This post has been changed because invalid HTML was found in the message body.

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: Upgrading from uCMDB 10.01 to 10.20 failed

Jump to solution

Workaround suggested by HP support did the trick:

 

The regional settings standard for our environments is dutch in wich the decimal separator is a , (comma)

For the service account which runs the UCMDB service, the decimal separator is set to a . (dot)

Now the installation continues.

 

We have seen more problems with the decimal  separator, also with the system health disk space monitors.

 

Nice to have a workaround, but weird that this was working in previous versions.

View solution in original post

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.