Highlighted
New Member.
177 views

Webpshere by Shell discovery error

UCMDB 10.2 CUP1.545 Content Pack 15.01.143

 

I'm running the Websphere by Shell discovery and while it is successful for a subset of my servers it is failing on the majority.  I am getting the following error when it fails.

 

<< Progress message, Severity: Error>>
Failed executing script, details: Traceback (most recent call last):
  File "<string>", line 2, in <module>
  File "websphere_by_shell", line 131, in DiscoveryMain
  File "file_topology", line 292, in dirName
  File "E:\hp\UCMDB\DataFlowProbe\jython\Lib\posixpath.py", line 119, in dirname
    return split(p)[0]
  File "E:\hp\UCMDB\DataFlowProbe\jython\Lib\posixpath.py", line 77, in split
    i = p.rfind('/') + 1
AttributeError: 'NoneType' object has no attribute 'rfind'

0 Likes
5 Replies
Highlighted
Outstanding Contributor.. Outstanding Contributor..
Outstanding Contributor..

Re: Webpshere by Shell discovery error

Hello Adam ,

 

Please review all the details about this discovery in this guide https://softwaresupport.hp.com/group/softwaresupport/search-result/-/facetsearch/document/KM01364385 .

 

After that , please run the issue and send us the communication.log .

 

Best Regards ,

Melissa Carranza Mejias
Customer Support Engineer

If you find that this or any other post resolves your issue, please be sure to mark it as an accepted solution.
If you are satisfied with anyone’s response please remember to give them a KUDOS by clicking on the STAR at the bottom left of the post and show your appreciation. “
0 Likes
Highlighted
New Member.

Re: Webpshere by Shell discovery error

 
0 Likes
Highlighted
New Member.

Re: Webpshere by Shell discovery error

Any update on this?  I'm still having this issue with my Websphere discovery.

0 Likes
Highlighted
Established Member..
Established Member..

Re: Webpshere by Shell discovery error

Looking at your communication log, 

 

The shell script is trying to access deployment.xml files but can not locate them via the path supplied.

 

I would suggest you log on to the trigger hosts and verify if the files exist and that the probe have the right permissions to read them.

0 Likes
Highlighted
New Member.

Re: Webpshere by Shell discovery error

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.