Highlighted
Absent Member.. Absent Member..
Absent Member..
428 views

host connection by shell problem with one CI

Hi

 

When host connection by shell  job ends for on server, it creates 4 CI-s: Windows and three Interfaces. It does not create a link between the IP and Windows CI. And it doesnt create ntcmd ci. Thus it does not run host application by shell.

uCMDB was 10.01 - upraded it to 10.10 and the result was the same

server is windows 2012

It says the job was completed.

 

On a similar machine (windows 2012), it creates ntcmd CI-s and host application by shell runs ok.

 

Has anyone idea where to look for the mistake. I think the Data Flow Probe doesnt get the neccesary info from the server.

Will this prevent the creation of ntcmd ci ?

 

Bests

Stream

0 Likes
4 Replies
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: host connection by shell problem with one CI

Could you please show us Communication log with enbled results in it?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: host connection by shell problem with one CI

Selected the option to log the results, rerun the discovery and it reported CIs correctly. I previosly ran the job maybe 4 times. I dont know what was different now.

0 Likes
Highlighted
Honored Contributor.. Honored Contributor..
Honored Contributor..

Re: host connection by shell problem with one CI

stream0,

 

Do you also run Host Connection by WMI on the same nodes that are also discovered with Host Connection by Shell (NTCMD)

 

If you do, check the history on that node. I've seen Windows CIs that are discovered with both WMI and NTCMD, the other discovery job will delete the other protocol CI.

An example is that if you run Host Connection by WMI then it creates a related WMI agent to the node. Then run Host Connection by Shell, the job then removes the WMI agent and create the NTCMD agent. I've seen a few instances of this.


The CI History will have these changes.

Rey Lejano

effectualsystems.com
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: host connection by shell problem with one CI

Hi

 

Thanks for the idea, but I am running only jobs by ntcmd. So this was not behind the problem.

 Thus far it seems to working fine.

 

 

Bests

stream0 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.