Highlighted
Super Contributor.
Super Contributor.
646 views

<UCMDB Support Tip> Manually change uCMDB Ports

Jump to solution

Topic 

By default, uCMDB uses the 8443 port to access the client. Sometimes it is necessary to change the port to avoid conflicts.

Response
1. Login to jmx-console 
2. Navigate to UCMDB:service=Ports Management Services >HTTPSSetPort
3. Type the port you want to set as new HTTPS port then invoke the operation.
4. Restart the ucmdb server and access the uCMDB server on the new port.

And you can find out more interesting settings in UCMDB:service=Ports Management Services

 

1 Solution

Accepted Solutions
Highlighted
Trusted Contributor.
Trusted Contributor.

Hi Shavrin,

 

yes you are correct. I modified the ports successfully using the parameter HTTPS port (Under menu Administration -> Infrastructure settings manager)

I attached an explaining screenshot

View solution in original post

7 Replies
Highlighted
Trusted Contributor.
Trusted Contributor.

Great.

It worked for me and helped me to avoid port 8443 conflict between OO and UCMD Server

0 Likes
Highlighted
Super Contributor.
Super Contributor.

i guess the same can be done from the UI - settings manager. 

 

0 Likes
Highlighted
Super Contributor.
Super Contributor.

and if it does not allow using the UI at all - i would try to add

jetty.connections.https.port=8444

jetty.connections.http.port=8081

into \conf\settings.override.properties file

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Hi Shavrin,

 

Would you please give the full path to the UI Setting Manager in order to change the ports.

As I didn't find it...

Thnx

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

By the way, I succeeded to update the port by adding

jetty.connections.https.port=8444

into \conf\settings.override.properties file

 

Thnx

0 Likes
Highlighted
Super Contributor.
Super Contributor.

hi,

I meant Administration -> Infrastructure settings manager -> search by name = http.

 

0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

Hi Shavrin,

 

yes you are correct. I modified the ports successfully using the parameter HTTPS port (Under menu Administration -> Infrastructure settings manager)

I attached an explaining screenshot

View solution in original post

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.