Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
409 views

scheduled reports

Hi

We have created a custom report and scheduled it to send the results via email.

But for some unknwon reason the scheduled report does not work.
The sending on demand of the report works correctly.

The following error is displayed in the error.log (attachment file):

Any ideas?

 

thanks.

 

 

 

0 Likes
14 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: scheduled reports

How did you define the schedule? Did you used a cron expression?
Kind regards,
Bogdan Mureșan
EMEA CMS Technical Success
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: scheduled reports

Selecting the report (Modeling/Reports) and click on Scheduled report icon.

It shows a window to define multiple parameters to scheduled the report (Name, Description, Locale, Actions, formats, Send To, Time Policy...)

to view the scheduled reports click on "Show Scheduled Reports Jobs" icon

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: scheduled reports

And what did you actually define there?
I'm interested in what scheduling option did you chose or enter.

 

 

Kind regards,
Bogdan Mureșan
EMEA CMS Technical Success
0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: scheduled reports

Do the mailing work at all? Can you send an email without scheduling? My experience is that mails don't work in the latest versions of UCMDB, for which I opened three support cases and they ended with patches (SD02493231, SD02498661, SD02488364)

 

Petko

Likes are appreciated!
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: scheduled reports

Hello JohnCI

We've attached two images with the scheduling options.

Thanks

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: scheduled reports

Hello popadiyski

 

The mail works well without scheduling. If I open a report and send it by mail (on-demand) works well

 

Thanks.

Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: scheduled reports

I see. Unfortunately the error.log which you have attached is not connected to the scheduling, but some authentication problem of sysadmin user. You have attach the whole error log for the period of scheduling as well as show us a screenshot of the error of the scheduler. You have attached a PENDING job. What happens when the time passes? Does it become "successful" or goes to error state? What is the error then?

 

Petko

Likes are appreciated!
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: scheduled reports

Hello popadiyski 

For test purposes we have scheduled a report today at 09:00AM and repeat at interval of 10 minutes.

The report called "Equipos con dongle USB JAWS". The scheduled options is showed in the attached image (scheduled_options.jpg)

At 09:10 in the job list of scheduled reports there aren't any errors. The current status of the report is PENDING. When the time passes the status still remains in PENDING.

At 09:12 In the job list if i run the job manually (click on the button says "Run job now", a message says "Job was successfully executed" but there are no mails.

We send you the whole error.log. I can see the same error at 09:00 and 09:10 (scheduled report) and at 09:12 (manually run the job).

 

Thanks.

0 Likes
Highlighted
Acclaimed Contributor.
Acclaimed Contributor.

Re: scheduled reports

It is possible the mail server is filtering the mail. I don't see any issue. Try with sending Direct URL only istead of pdf and xls attachments.

And just to confirm - you have configured "Email sender" in the Mail Infrastructure Settings?

 

Petko

Likes are appreciated!
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: scheduled reports

Hello Petko,

 

the first Support case was a known issue fixed in 2019.05, unfortunately, you had no chance of catching it as it wasn't properly documented. Now it is. You will notice that QCCR1H125880 has you thread ID in the error message.

For the second one, we had the known issue with QCCR1H126262 that has a patch for the email sending flow with SSL disabled (we wrongly assumed that SSL is always on, it's fixed now). Due to this CR you received very quickly QCCR1H126793 which is actually the same fix but extended to the scheduled email reports.

The third support case was the one in which you received the patch for the above-mentioned QCCR1H126262.

These issues were reported on 11.3, 11.4 and 11.5 versions. Interesting.

Kind regards,
Bogdan Mureșan
EMEA CMS Technical Success
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: scheduled reports

What's your UCMDB version?
Are you using SMTP with SSL disabled?
Kind regards,
Bogdan Mureșan
EMEA CMS Technical Success
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.