Highlighted
Absent Member.
Absent Member.
314 views

uCMDB Tip: Changing the chunk size for the uCMDB to XML integration

Hello all,

 

We had a case where customer wanted to export from uCMDB to XML a lage quatity of CIs. They encountered and error like:

 

Caused by: com.hp.ucmdb.synchronizer.SynchronizerException: [ErrorCode [860] Error occurred while running synchronization. See statistics for more information]

com.mercury.topaz.cmdb.shared.base.CmdbException: [ErrorCode [-2147483648] undefined error code]

java.lang.RuntimeException: Chunk overflow. Current chunk size: 8209; allowed max size: 2000

 

To solve this issue go to the adapter XML Export Adapter -> right click on XmlPushAdapter and edit adapter source.

 

Check for this:

<adapter-settings>

            <adapter-setting name="replication.chunk.size">2000</adapter-setting>

</adapter-settings>

 

By default it should be 2000. You can increase this number and you will have a smaller number of chunks. Integration should work after this modification.

 

There is another setting with the same name in Infrastructure Settings Manager. IT IS NOT THE SAME, DO NOT USE THAT SETTING!

 

Best regards,

Andrei Matei

Best regards,
Andrei Matei
uCMDB Support Engineer

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
Labels (1)
Tags (1)
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.