Highlighted
Absent Member.. Absent Member..
Absent Member..
220 views

uCMDB problem

Jump to solution

I can not open Discovery Control Panel. It loads for a second and then nothing and it doesnt give any errors. I have tryed to access it from different computers, from the server, with different users. Restarted service, restarted server. Looked thru log files, but nothing caught my eye. 

 

I tried even updateing to CUP 7 but still the issue presist. 

 

I attached part of the error log, which might be the cause.

0 Likes
1 Solution

Accepted Solutions
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: uCMDB problem

Jump to solution

I guess the problem in a missing template that is used in one of zones/activites.

My suggestion, is to open support case, since manual intervention will be needed. If this is a sandbox, recreation of DB will do the magic as well

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.

View solution in original post

13 Replies
Highlighted
Absent Member.
Absent Member.

Re: uCMDB problem

Jump to solution

Hello,

 

Can you give a little more details about your configuration? uCMDB version, CUP.

Also can you tell me if you are using HA with load balancer?

Best regards,
Andrei Matei
uCMDB Support Engineer

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: uCMDB problem

Jump to solution

uCMDB 10.01 CUP 7.489

 

Wierd thing is that everything else works and opens.

 

I even deleted the probe and reattached it. I touch maybe some job or management zone which was attached to it was conflicting somehow. 

 

Is there a way to reset discovery control panel from eg JMX Console ?

 

 

If I am not mistaken then no, for that server there is no load balancing

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: uCMDB problem

Jump to solution

Could you please publish client logs from %TEMP%\UCMDBLog folder on the machine where browser running?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: uCMDB problem

Jump to solution

Attached are the logs. 

 

Bests

stream0

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: uCMDB problem

Jump to solution

Hello!

 

Can you try setting the mam.common.secure.communication value to false?  To do this, go to the JMX Console:  

http[s]://<UCMDB_Server>:<Port>/jmx-console

UCMDB:service=Settings Services, invoke the

setSettingValue method with the arguments:

customerID: 1

name: mam.common.secure.communication

value: false

 

Then log out and log in to the GUI.  Can you now access the page in question?


Thanks;

 

Keith Paschal
HP UCMDB Support

Hope this helps,
Keith Paschal
UCMDB Worldwide Support Lead
Micro Focus Support
If you find this or any post resolves your issue, please be sure to mark it as an accepted solution."

Click the KUDOS star on the left to say 'Thanks'
0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: uCMDB problem

Jump to solution

What was a last action related to Management zones and activities before failure?

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.
0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: uCMDB problem

Jump to solution

I cant remember exactly, as I was createing and deleting zones and also templates. There where couple of jobs active in two zones - Host connection/resources/application by WMI and MS SQL database connection/topology

 

I might have deleted from resources a discovery wizard template which actually was active. - Maybe this was the cause?

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: uCMDB problem

Jump to solution

Sadly setting the mam.common.secure.communication to false did not help. 

0 Likes
Highlighted
Acclaimed Contributor.. Acclaimed Contributor..
Acclaimed Contributor..

Re: uCMDB problem

Jump to solution

I guess the problem in a missing template that is used in one of zones/activites.

My suggestion, is to open support case, since manual intervention will be needed. If this is a sandbox, recreation of DB will do the magic as well

Regards
-Dmitry Gomel, PMP
Click the Like button at the bottom to say 'Thanks'.

View solution in original post

Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: uCMDB problem

Jump to solution

I will go with the DB recreation. I will let you know if this solves the problem. 

0 Likes
Highlighted
Absent Member.. Absent Member..
Absent Member..

Re: uCMDB problem

Jump to solution

Hi

 

We rolled the DB back and it now opens. Thanks for help

 

 

Bests

stream0

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.