Highlighted
Super Contributor.. Super Contributor..
Super Contributor..
285 views

zSai Files directories and "workflow"

Jump to solution

Hello,

 

As i edit from the UI "Software Library" , we could see the version of each zSAI files (Master, Unix, etc ....)

In order to well understand how the deployment is done to each Probe, i can see

- on the uCMDB server side : Base directory, Full Directory in UCMDBServer\runtime\sai => which version is supposed to be "read" when we open "SoftwareLibrary" form the UI ?

- between the Full and Base directory the version is different, and the last seems to be set in "Full" directory

- in the last update CP4, i can see "*.delta.zsai" files => i supposed the these files arre renamed and set in Full directory ?

- then this filles are supposed to be "deployed" on each Probe server in directory runtime\probeManager\discoverySaiResources\saiRuntime .. isn't it ?

 

I want to understand the mechanism is this kind of deployement, decause we encountered a strange behaviour : 

 - the version show by the software library from the UI doesn't match with the version in the uCMDB Full directory (but wiht the Base directory

- on some Probe server, the version in the runtime\probeManager\discoverySaiResources\saiRuntime doesn't match with the version Full directory on uCMDb server

- on some Probe server, some "*.delta.zsai" appearthe version in runtime\probeManager\discoverySaiResources directory, and not on some other server

 

I have try to re-apply CP14U4 Patch, but without success ...

So, what can i do "manually" to be able to use (and deploy) the last zsai files ??

 

thanks in advance

 

P.S We work with 10.11 version CUP 2 CP14Update4

0 Likes
1 Solution

Accepted Solutions
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: zSai Files directories and "workflow"

Jump to solution

Hi Stephane,

 

 Thank you for providing the data.

 

It looks a bit strange:

 

  - On the server side:

in \hp\UCMDB\UCMDBServer\runtime\sai\base - there are correct SAIs from the original CP14 (June Master SAI - 4/6/14)

in \hp\UCMDB\UCMDBServer\runtime\sai\full - there are old SAis from September 2013  (September Master SAIs - 30/08/13

 

 - On the Probe side:

 

in \hp\UCMDB\DataFlowProbe\runtime\probeManager\disco​verySaiResources\baseline - there are SAIs from September 2013 (September Master SAI - 30/08/13)

in \hp\UCMDB\DataFlowProbe\runtime\probeManager\disco​verySaiResources\saiRuntime  - there are SAIs from March 2014 (March Master SAI - 28/2/14)

 

 - Delta zsais on the Probe are corect ones from CP14 Update 4 (December Master SAI - 05/12/14), but they can not be combined with the baseline SAis, since those are not from CP14

 

It is not clear what really happened, it lookes like previously there was a problem with the SAI deployment on the Probe side and somehow on the Server, the SAis were not updated either.

 

I would suggest to try to re-deploy the SAI.zip package from the original CP14 and then try to re-deploy the SAi.zip package from CP14 Update 4 (or the complete CP14 Update4).

 

Kind regards,

Irina

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

Click the KUDOS star on the left to say 'Thanks'

View solution in original post

0 Likes
8 Replies
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: zSai Files directories and "workflow"

Jump to solution

Hi Stephane,

 

The mechanism of the zSAI deployment works as follows:

 

 - First you apply the original Content Pack (in this case Content Pack 14), so in the Base directory you should see the SAIs from the original CP14.

 - After that you apply CP updates, which contain delta zsai files. Delta zsai files are used to update the "base" SAIs and you should see the updated version in the UCMDB UI. They are in the binary format and not possible to view, they should be "combined" with the Base sais. So the full directory will contain the latest version of the SAI files ("base SAI+ delta zsai" combined).

 

 - It is important that CP updates are applied on the correct Content Pack. It looks that on some of your servers CP 14 base SAIs were not properly deployed, as a result delta zsai are not comined with the original SAis.

 

 - Could you please check what is the date for the SAIs that you have in the Base directory? They shoudl be after June 2014, if not, please re-apply SAI.zip package from the original CP 14 to make sure that you have correct SAIs in the Base directory .

 

Kind regards,

Irina 

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

Click the KUDOS star on the left to say 'Thanks'
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: zSai Files directories and "workflow"

Jump to solution

Hello Irina,

 

I've check zsai files in Base Directory => creation date is 25/06/2014 for all zsai ...

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: zSai Files directories and "workflow"

Jump to solution

Hi Stephane,

 

Could you please provide Mac.zsai from the Base directory, I would like to check a couple of things.

 

Kind regards,

Irina

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

Click the KUDOS star on the left to say 'Thanks'
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: zSai Files directories and "workflow"

Jump to solution

Here it is Irina ...

 

thanks in advance for your help

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: zSai Files directories and "workflow"

Jump to solution

Thanks Stephane. Yes, this is indeed the original CP 14 SAI.

 

Could you please provide the following:

 

 - Open command prompt on the UCMDB Server machine and provide dir/s output from

\hp\UCMDB\UCMDBServer\runtime\sai\base and

\hp\UCMDB\UCMDBServer\runtime\sai\full

 

 - Please provide Mac.zsai from \sai\full directory

 - Please provide mam.packaging.log from \hp\UCMDB\UCMDBServer\runtime\log

 

 - Open command prompt on the Probe machine where you see the issue and provide dir/s output from:

\hp\UCMDB\DataFlowProbe\runtime\probeManager\discoverySaiResources\baseline  and \hp\UCMDB\DataFlowProbe\runtime\probeManager\discoverySaiResources\saiRuntime

 

 - Please provide Mac.zsai from both directories on the Probe

 

Kind regards,

Irina

 

 

 

 

 

 

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

Click the KUDOS star on the left to say 'Thanks'
0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: zSai Files directories and "workflow"

Jump to solution

Irina,

 

I've just uploaded all the files you requested ...

0 Likes
Highlighted
Micro Focus Frequent Contributor
Micro Focus Frequent Contributor

Re: zSai Files directories and "workflow"

Jump to solution

Hi Stephane,

 

 Thank you for providing the data.

 

It looks a bit strange:

 

  - On the server side:

in \hp\UCMDB\UCMDBServer\runtime\sai\base - there are correct SAIs from the original CP14 (June Master SAI - 4/6/14)

in \hp\UCMDB\UCMDBServer\runtime\sai\full - there are old SAis from September 2013  (September Master SAIs - 30/08/13

 

 - On the Probe side:

 

in \hp\UCMDB\DataFlowProbe\runtime\probeManager\disco​verySaiResources\baseline - there are SAIs from September 2013 (September Master SAI - 30/08/13)

in \hp\UCMDB\DataFlowProbe\runtime\probeManager\disco​verySaiResources\saiRuntime  - there are SAIs from March 2014 (March Master SAI - 28/2/14)

 

 - Delta zsais on the Probe are corect ones from CP14 Update 4 (December Master SAI - 05/12/14), but they can not be combined with the baseline SAis, since those are not from CP14

 

It is not clear what really happened, it lookes like previously there was a problem with the SAI deployment on the Probe side and somehow on the Server, the SAis were not updated either.

 

I would suggest to try to re-deploy the SAI.zip package from the original CP14 and then try to re-deploy the SAi.zip package from CP14 Update 4 (or the complete CP14 Update4).

 

Kind regards,

Irina

 

“HP Support
If you find that this or any post resolves your issue, please be sure to mark it as an accepted solution.”

Click the KUDOS star on the left to say 'Thanks'

View solution in original post

0 Likes
Highlighted
Super Contributor.. Super Contributor..
Super Contributor..

Re: zSai Files directories and "workflow"

Jump to solution

Hello Irina,

 

thank you for all !!!

 

all is ok now !

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.