Having problems with your account or logging in?
A lot of changes are happening in the community right now. Some may affect you. READ MORE HERE

Getting Error message "Quality Center libraries installed are incompatible with Quality Center version you are trying to connect to. CaliberRM may not work with this server"

Getting Error message "Quality Center libraries installed are incompatible with Quality Center version you are trying to connect to. CaliberRM may not work with this server"

Problem:

Getting Error message "Quality Center libraries installed are incompatible with Quality Center version you are trying to connect to. CaliberRM may not work with this server"

Resolution:

  • Product Version: CaliberRM 2006
  • Product Component: Integration
  • Platform/OS Version: All supported platform of CaliberRM
  • External Integration Software: Mercury Quality Center version 9.0


Description:

When trying to trace a requirement to a test plan/test lab in Mercury 9.0 Object, the following error message is received.

"Quality Center libraries installed are incompatible with Quality Center version you are trying to connect to. CaliberRM may not work with this server"


Answer/Solution:

As the QCIntegrationAddin.dll file in CaliberRM works with both Mercury Quality Center 8.2 SP1 and 9.0. By default if nothing is stated, the QCIntegrationAddin will assume that the Quality Center used is version 8.2 SP1.

In order for it to work for Mercury Quality Center 9.0, the version number of the Mercury Quality Center must be stated inside the Quality Center Configuration File.

In the CaliberRM Administrator, select View > Projects from the menu.

Select the project for which you want to edit the Mercury configuration.

Select the External Traceability tab.

Select Quality Center and click Edit. The Edit Integration dialog box opens.

Click Modify to edit the contents of the configuration file in the Configuration for ?Quality Center?
Integration text editor. You can specify the addresses of one or more Mercury servers of a single
version. Add a second line if it does not exist to specify the version of Quality Center you are using.
The syntax of this line is version.N where N is the configuration file line number that specifies the
Quality Center URL. You may define multiple Quality Center servers in the file, each should have a
matching Version.N= line. For a single Quality Center server version 9.0, the second line of the
configuration file should be Version.1=90.

e.g

http://localhost:8080/qcbin
version.1=90


Author : Elaine Lim

Old KB# 15825

DISCLAIMER:

Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
Version history
Revision #:
1 of 1
Last update:
‎2013-02-15 18:26
Updated by:
 
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.