Ian Pletcher Absent Member.
Absent Member.
2138 views

Removing blank line at end of every requirement in word table

Jump to solution

Is it possible to output a table of requirements using the document factory without having a blank line at the end of every row?

Currently every requirements template I have is producing a document that is many more pages than should be the case because there is a blank line at the end of each requirement in the table.

Here is the docfactory template for a table

If I run this template, I get a carriage return at the end of the description followed by the word end of row character on a new line.

This results in an output that looks like this:

Unlike some of the minor formating anomalies that come out of the document factory I have been unable to find a way in Word to quickly replace multiple instances of a paragraph end followed by a row end character with just a row end marker. It is simple to manually delete the end of paragraph character at the end of each description, but this is tedious in a document containing 100s of requirements. The end result of this issue is documents that are 10 - 40% longer than they need to be.

I tried to change the template to resolve the problem as follows:

 

However, the result of putting the $END_ROW command on the same line as <<description>> is that the document factory does not output the description at all.

In the grand scheme of things it's not a major problem, but it has been bugging me. Does any one have any suggestions?

 

 

 

 

0 Likes
1 Solution

Accepted Solutions
Highlighted
JosephOD Absent Member.
Absent Member.

RE: Removing blank line at end of every requirement in word table

Jump to solution

Hi Ian,

This description issue is fixed in the next release of Caliber 11.1, this service pack will be released shortly. This change will then be ported back to subsequent versions.

Regards,

Joseph

0 Likes
1 Reply
Highlighted
JosephOD Absent Member.
Absent Member.

RE: Removing blank line at end of every requirement in word table

Jump to solution

Hi Ian,

This description issue is fixed in the next release of Caliber 11.1, this service pack will be released shortly. This change will then be ported back to subsequent versions.

Regards,

Joseph

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.