Anonymous_User Absent Member.
Absent Member.
812 views

CG Unix Agent Install Failure


I am attempting to install a CG for Unix agent on some Ubuntu boxes
using the UNIX Agent Manager but the process failures with the following
error: Failed to change to temporary directory - /tmp/vsau.tmp

Confirmed account used has permissions and I am able to sudo as well as
create files in the directory. If I SSH in manually it works fine. Is
there an issue with the agent manager sudo'ing? No idea as the
documentation does not speak to the issue.


--
psmcgovern
------------------------------------------------------------------------
psmcgovern's Profile: https://forums.netiq.com/member.php?userid=5730
View this thread: https://forums.netiq.com/showthread.php?t=51942

0 Likes
1 Reply
Anonymous_User Absent Member.
Absent Member.

Re: CG Unix Agent Install Failure


Just figured this out. Ubuntu is not supported. There is a workaround
however. Basically you need to trick the agent into thinking the system
is RHEL. First create a file under /etc called
Code:
--------------------
redhat-release
--------------------


Use nano or another text tool to insert the following text:

Code:
--------------------
Red Hat Enterprise Linux Server release 4 (Tikanga)
--------------------


They key issue with getting the agent to run in Ubuntu is installed the
ia32-libs 32-bit library. This is no longer maintained in current
repositories.

Now if you are using Ubuntu 12.04 LTS or newer you will need to "pin"
the repository packages to an older version of Ubuntu. I was working on
12.04. To this end I created a new file under /etc/apt called
preferences. If using version 12.04 enter the following text with nano
or your favorite text editor:

Code:
--------------------
Package: *
Pin: release a=precise*
Pin-Priority: 2012
--------------------


Then run the following to upgrade apt:

Code:
--------------------
sudo apt-get update
sudo apt-get dist-upgrade
--------------------


Reboot the machine

Then install ia32-libs:

Code:
--------------------
sudo apt-get install ia32-libs-multiarch
--------------------


Please note that you may need to install a series of dependencies first.
The system will prompt you for these.

Then install the agent like normal and start the agent. You should be
all set.


--
psmcgovern
------------------------------------------------------------------------
psmcgovern's Profile: https://forums.netiq.com/member.php?userid=5730
View this thread: https://forums.netiq.com/showthread.php?t=51942

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.