marcohald Regular Contributor.
Regular Contributor.
605 views

Agent does not register

Hi,

I have build an agent 2017 Update 4 with embedded registration key.
The Agent installation is working without any problem.
But the Agent is not registered on any server.
It has definitely worked on 2017 Update 2.
A manual Registration with zac reg works.
In what log file should I look ?
Labels (1)
0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

Re: Agent does not register

zmd-messages.log on the Client
services-messages.log on the Server

May want to compare the "initial-web-service" file that gets installed on U2 vs U4
0 Likes
marcohald Regular Contributor.
Regular Contributor.

Re: Agent does not register

Hi Craig,

thanks for the hint to the Logfiles.
I have deleted the Device with the "Unregister Device" Option before I re imaged it.

In the services-messages.log
[DEBUG] [02/20/2019 08:01:20.771] [1810] [ZENService] [11922] [] [Registration Web Service] [] [Received device registration request for 7a4cb8d8e3b8794a828585ca804d86ed] [] [] [] [ZENServer]
[DEBUG] [02/20/2019 08:01:20.775] [1810] [ZENService] [11922] [] [Registration Web Service] [] [Device has previuously been deleted: 7a4cb8d8e3b8794a828585ca804d86ed] [] [] [] [ZENServer]
[TRACE] [02/20/2019 08:01:20.787] [1810] [ZENService] [11922] [] [Registration Web Service] [] [registerDevice complete, time: 16ms, code: -29, device: 7a4cb8d8e3b8794a828585ca804d86ed, thread: 11922] [] [] [] [ZENServer]


the zmd-messages.log there is an similar message.

[DEBUG] [02/20/2019 08:01:20.921] [2704] [ZenworksWindowsService] [9] [] [RegistrationManager] [] [Object Not Found Server Error: Device has previously been deleted: 7a4cb8d8e3b8794a828585ca804d86ed] [] [] [] [ZENworks Agent]
[DEBUG] [02/20/2019 08:01:20.922] [2704] [ZenworksWindowsService] [9] [] [RegistrationManager] [] [Error during device registration: Kein Objekt f�r GUID gefunden: 7a4cb8d8e3b8794a828585ca804d86ed.] [] [] [] [ZENworks Agent]


The Problem is maybe, that i used "Unregister Device" and imaged it after that without clearing the guid.
0 Likes
marcohald Regular Contributor.
Regular Contributor.

Re: Agent does not register

Is there a command to clear the guid in the MDT Environment ?
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Agent does not register

Try running select * from zzenobject where tobedeleted=1

If this returns values.....
Wait an hour and try again....
Hopefully none will be the same....if so there could be something getting "stuck" in deletion.....

Oddly....This sounds like very old "Working as Designed Behavior"....
https://support.microfocus.com/kb/doc.php?id=7002122

However, this was written back for ZCM 10.1, and device Registration has change very significantly many times since then.

Is the Device in the zDeletedDevice table?
Does clearing it help?

Don't mess there unless you know what you are doing and don't clear more than 1 device entry.....

What happens if you install an agent that does NOT use a registration key?
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Agent does not register

OK, this is "Working as Designed".

The "Unregister Device" action places the device into the "zDeletedDevice".
Devices listed here will not re-register to the zone except for an explicit "zac reg".

Just Delete the device instead of Unregistering from the "Actions" Menu in the ZCC.
That appears to be the only place left that may place devices there.

However....It's a very useful feature to help ensure a device does not come back automatically.....
I was stumped the other day on how to do this en-masse for another customer.

Note: I've made a ZCC Help doc bug to help clarify the details around that action.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.