Anonymous_User Absent Member.
Absent Member.
832 views

Agent don't update

Hi,

I tried to find out why many devices don't update the agent to 11.4.1.X.

I was looking at TID7001305. Is that TID applicatble to ZCM 11.4.1 ?

Here's the log I receive when I try what's indicated.

Thanks for help.


java.lang.NullPointerException
at
com.novell.zenworks.webservice.systemupdate.SystemUpdateWebService.getAssignedSystemUpdateCommands(SystemUpdateWebService.java:69)
at
com.novell.zenworks.webservice.systemupdate.SystemUpdateService_ServiceTieSkeleton.getAssignedSystemUpdateCommands(SystemUpdateService_ServiceTieSkeleton.java:62)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at com.novell.soa.ws.impl.rpc.GetSupport.invoke(GetSupport.java:1109)
at com.novell.soa.ws.impl.rpc.GetSupport.doGet(GetSupport.java:223)
at com.novell.soa.ws.impl.rpc.GetSupport.doGet(GetSupport.java:2127)
at
com.novell.soa.ws.impl.rpc.ServerDelegateImpl.doGet(ServerDelegateImpl.java:127)
at
com.novell.soa.ws.server.ServletSkeleton.doGet(ServletSkeleton.java:281)
at
com.novell.zenworks.webservice.systemupdate.SystemUpdateService_ServiceTieSkeleton.doGet(SystemUpdateService_ServiceTieSkeleton.java:40)
at
com.novell.zenworks.webservice.systemupdate.SystemUpdateServiceImpl.doGet(SystemUpdateServiceImpl.java:147)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:624)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:731)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
at
org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
at
com.novell.zenworks.webservice.lib.AuthenticationFilter.doFilter(AuthenticationFilter.java:242)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
at
com.novell.zenworks.webservice.lib.StatisticFilter.doFilter(StatisticFilter.java:77)
at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:614)
at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170)
at
com.googlecode.psiprobe.Tomcat70AgentValve.invoke(Tomcat70AgentValve.java:39)
at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
at
com.novell.zenworks.tomcat.ZENRequestValve.synchronousInvoke(ZENRequestValve.java:1442)
at
com.novell.zenworks.tomcat.ZENRequestValve.invoke(ZENRequestValve.java:849)
at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:423)
at
org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1079)
at
org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:620)
at
org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:318)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at
org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.lang.Thread.run(Thread.java:745)

Labels (2)
0 Likes
10 Replies
Micro Focus Expert
Micro Focus Expert

Re: Agent don't update

Highly unlikely that TID has anything to do with your issue.
System Updates are in essence no different than any other bundle assignment.

Are the devices performing full refreshes? Is the content on their content server? etc....
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent don't update

Craig,

Sorry for the long delay.

On devices that aren't applying 11.4.1 agent update, everything seems to be
OK. Devices are doing full refresh, I only have 1 primary server so
content is there, etc. In the assigned system updates, I can see that
"Update for Zenworks 11 SP4 (11.4.1)" is assigned but it never applies.

Can I run a process to force agent update or should I uninstall 11.3.2.XXX
agent and reinstall 11.4.1 agent ?

Thanks.

Normand



"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.7bmb2n@no-mx.forums.microfocus.com...


Highly unlikely that TID has anything to do with your issue.
System Updates are in essence no different than any other bundle
assignment.

Are the devices performing full refreshes? Is the content on their
content server? etc....


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Novell or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=497043

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Agent don't update

Unfortunately, I'm not sure WHY the 11.3.x agents are not updating.
An SR may help, where a Tech can dig deep.

It is possible to roll your own SU if you are good with low level stuff.
You can grab the SU files and XMLs off a PC that did upgrade, tweak the XMLs so they point to a fixed location such as C:\My1141SU and then manually run zenupdater.exe

Mind you that is not officially supported but IF done correct would replicate exactly what the SU does.
If doing that, I would use https://forums.novell.com/entry.php/50-ZENworks-Agent-Verify-2-0 to spot check a few to make sure they are updating correctly.

If it is only a handful, an uninstall and reinstall may be the easiest way.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent don't update

Craig,

Where are located SU files on a device that is already updated ?

I'll try your solution.

For the SR, as an educational institution, we don't have support from Novell
(MicroFocus).

Thanks.

Normand



"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.7f9060@no-mx.forums.microfocus.com...


Unfortunately, I'm not sure WHY the 11.3.x agents are not updating.
An SR may help, where a Tech can dig deep.

It is possible to roll your own SU if you are good with low level stuff.
You can grab the SU files and XMLs off a PC that did upgrade, tweak the
XMLs so they point to a fixed location such as C:\My1141SU and then
manually run zenupdater.exe

Mind you that is not officially supported but IF done correct would
replicate exactly what the SU does.
If doing that, I would use
https://forums.novell.com/entry.php/50-ZENworks-Agent-Verify-2-0 to
spot check a few to make sure they are updating correctly.

If it is only a handful, an uninstall and reinstall may be the easiest
way.


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Novell or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm

-
What's the future of ZENworks and how can you get involved as it evolves
to a converged Unified Endpoint Management solution?
We're entering beta soon and want your feedback, click '*-here-*'
(https://www.novell.com/communities/coolsolutions/zenworks-2016-enter-next-phase-life/)
to find out more.-
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=497043

0 Likes
Not applicable

Re: Agent don't update

You should find System Update Content/files in C:\Program Files (x86)\Novell\ZENworks\ZeUS\cache\ZeUSCache (11.4 and newer)

System update logs: C:\Program Files (x86)\Novell\ZENworks\logs\system-update\50110401........
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent don't update

strj500,

I copied the ZeUSCache folder from an updated device.

Do you know which XML files should I edit to point to the temp location ?

Thanks for help.

Normand



"strj500" a écrit dans le message de groupe de discussion :
strj500.7f9pmn@no-mx.forums.microfocus.com...


You should find System Update Content/files in C:\Program Files
(x86)\Novell\ZENworks\ZeUS\cache\ZeUSCache (11.4 and newer)

System update logs: C:\Program Files
(x86)\Novell\ZENworks\logs\system-update\50110401........


--
strj500
------------------------------------------------------------------------
strj500's Profile: https://forums.novell.com/member.php?userid=157671
View this thread: https://forums.novell.com/showthread.php?t=497043

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent don't update

Craig,

I looked on a device that isn't updated. All 11.4.1 files are under
"C:\Program Files (x86)\Novell\ZENworks\ZeUS\cache\ZeUSCache". If I run
zenupdater.exe manually, I have those errors (sorry it's in French I
translate it):

Problem signature:
Event name problem: CLR20r3
Problem signature 01: ZENUpdater.exe
Problem signature 02: 11.4.1.4814
Problem signature 03: 563facec
Problem signature 04: mscorlib
Problem signature 05: 4.6.1076.0
Problem signature 06: 56d79d90
Problem signature 07: 186f
Problem signature 08: 20
Problem signature 09: System.ArgumentNullException
System version: 6.1.7601.2.1.0.256.48
Regional settings identifier: 3084
Additional Information n° 1: 4def
Additional Information n° 2: 4def3b33d7c7278176a1e1e2092c5cd4
Additional Information n° 3: 77c3
Additional Information n° 4: 77c339f0df3c814d14c20ef076093eaf

Maybe that's why SU 11.4.1 didn't worked fine when running zenupdater ?

What can I do ?

Normand




"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.7f9060@no-mx.forums.microfocus.com...


Unfortunately, I'm not sure WHY the 11.3.x agents are not updating.
An SR may help, where a Tech can dig deep.

It is possible to roll your own SU if you are good with low level stuff.
You can grab the SU files and XMLs off a PC that did upgrade, tweak the
XMLs so they point to a fixed location such as C:\My1141SU and then
manually run zenupdater.exe

Mind you that is not officially supported but IF done correct would
replicate exactly what the SU does.
If doing that, I would use
https://forums.novell.com/entry.php/50-ZENworks-Agent-Verify-2-0 to
spot check a few to make sure they are updating correctly.

If it is only a handful, an uninstall and reinstall may be the easiest
way.


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Novell or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm

-
What's the future of ZENworks and how can you get involved as it evolves
to a converged Unified Endpoint Management solution?
We're entering beta soon and want your feedback, click '*-here-*'
(https://www.novell.com/communities/coolsolutions/zenworks-2016-enter-next-phase-life/)
to find out more.-
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=497043

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent don't update

Craig,

Also, on some devices, ZeUSCache folder isn't there but in agent properties,
modules version is 11.4.1.4825 but version.txt file isn't updated and
content still at 11.3.2.62162 FTF Roll Up 1.

Any help about this ?

Thanks.

Normand



"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.7f9060@no-mx.forums.microfocus.com...


Unfortunately, I'm not sure WHY the 11.3.x agents are not updating.
An SR may help, where a Tech can dig deep.

It is possible to roll your own SU if you are good with low level stuff.
You can grab the SU files and XMLs off a PC that did upgrade, tweak the
XMLs so they point to a fixed location such as C:\My1141SU and then
manually run zenupdater.exe

Mind you that is not officially supported but IF done correct would
replicate exactly what the SU does.
If doing that, I would use
https://forums.novell.com/entry.php/50-ZENworks-Agent-Verify-2-0 to
spot check a few to make sure they are updating correctly.

If it is only a handful, an uninstall and reinstall may be the easiest
way.


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Novell or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm

-
What's the future of ZENworks and how can you get involved as it evolves
to a converged Unified Endpoint Management solution?
We're entering beta soon and want your feedback, click '*-here-*'
(https://www.novell.com/communities/coolsolutions/zenworks-2016-enter-next-phase-life/)
to find out more.-
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=497043

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Agent don't update

You got an error due to invalid command line arguments.

See https://www.novell.com/support/kb/doc.php?id=7000751

If you have a device that is mostly 11.4.1 but the version has not updated, it could indicate that one or more components failed or it rebooted too soon...was shutoff, etc....
Rerunning the System Update per the TID can help.

The TID also shows where the Update Configuration File is located that would need to be updated so that it pulled files from a specific location and not the cache folder, since the files would not be in cache or even if so not the same location across devices.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent don't update

So I just went through the same issue after pushing the 11.4.1 update to
9600 devices. upgrades were a mix of 11.2.3 and 11.3.2a. I have about 130
working devices left that just won't take no matter what zac cc, zac ref etc
you do. Now my following suggestion all depends on how much historical data
you need from the device. Such as inventory, patch history etc. If that’s
not important to you then do the following as I have. un register the device
(zac unr) and then register the device (zac reg.....) manually. Since you
have set the zone to base line this will kick the upgrade on the device as
soon as it registers and the system see it is out of compliance. Works for
me every time. If you want to open an SR and take the time for them to tell
you how to fix one computer you can. But my experience after several
upgrades is I always have devices that just won't upgrade and this is the
easiest quickest way to just get er done 🙂

"Normand Hudon" wrote in message
news:qqHWy.864$6A1.2@novprvlin0913.provo.novell.com...

Craig,

Sorry for the long delay.

On devices that aren't applying 11.4.1 agent update, everything seems to be
OK. Devices are doing full refresh, I only have 1 primary server so
content is there, etc. In the assigned system updates, I can see that
"Update for Zenworks 11 SP4 (11.4.1)" is assigned but it never applies.

Can I run a process to force agent update or should I uninstall 11.3.2.XXX
agent and reinstall 11.4.1 agent ?

Thanks.

Normand



"CRAIGDWILSON" a écrit dans le message de groupe de discussion :
CRAIGDWILSON.7bmb2n@no-mx.forums.microfocus.com...


Highly unlikely that TID has anything to do with your issue.
System Updates are in essence no different than any other bundle
assignment.

Are the devices performing full refreshes? Is the content on their
content server? etc....


--
--
Any Opinions, Thoughts, Solutions, or Blog Entries are my own and may or
may not be shared by Novell or any Sane Person
Please Use at your Own Risk.

Blog - https://forums.novell.com/blog.php/5830-CRAIGDWILSON

https://ideas.microfocus.com/mfi/novell-zcm
------------------------------------------------------------------------
CRAIGDWILSON's Profile: https://forums.novell.com/member.php?userid=5830
View this thread: https://forums.novell.com/showthread.php?t=497043

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.