Anonymous_User Absent Member.
Absent Member.
1624 views

Agent not connecting to server

Hi,

We are encountering some problems regarding the association of
packages/policies and login with the scum agent.

The environment consists of:
- ZCM 10
- Windows only environment (AD, 2003)
- Windows XP SP2 Clients
- ZCM installed on 1 of the 3 DC's (Not the "PDC")

The installation of ZCM didn't give us any error messages.
We've also been able to configure a AD user source.

After we wanted to deploy our first test bundles, we discovered that the ZCM
agent didn't login. After sorting out all kind of possible issues (DNS, Time
Sync etc.) we now think that it has something to do with the ZCM
certificates. (We choose internal authority at the installation of ZCM)

The agent properties shows the following infos:
- Correct client address
- Correct hostname
- Last contact with server: never
- next contact with server: is being re-scheduled every minute.
- primary user: n/a
- Correct ZCM Zone
- Correct ZCM Server FQDN
- Correct ZCM Server IP-address

Attached you'll find our "zmd messages" log file from one of our client
computers.

Please let me know if you need any additional information.
Thanks a lot.

Best regards
Thomas




Labels (2)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Thomas,

plenty of
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Found host Company05.Company.loc status: Bad] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Skipping IP address 192.168.100.14, status Bad] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Found host 192.168.100.14 status: Bad] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Skipping IP address 192.168.100.14, status Bad] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [Trying to locate source location: https://Company05.Company.loc/zenworks-containmentlookup/] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Host name to resolve: Company05.Company.loc] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Found host: Company05.Company.loc, status: Bad] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Skipping host: Company05.Company.loc, status: Bad] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [Trying to locate source location: https://192.168.100.14/zenworks-containmentlookup/] [] []
[DEBUG] [21.09.2007 14:39:44] [] [ConnectMan] [] [ Host name to resolve: 192.168.100.14] [] []

can't contact the server...

--

Shaun Pond


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Shaun,

We've also seen these entries.
We're able to:

- Ping the ZCM Server over ip and hostname
- DNS resolution works
- File copy to and from the ZCM server work

How should we continue to investigate this?

Regards,
Thomas




0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Shaun,

I've attached you a more reading friendly part of the .log file.
So you don't have to read through 100 pages.

Cheers,
Thomas


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Here you go...




0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Thomas,

set the log level to debug, reboot, and look for the first entry since
booting...

--

Shaun Pond


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Shaun,

Here is the new log file, debug log level and the portion from after the
reboot.


Cheers




0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Agent not connecting to server

Thomas,

there have been some issues with German agents - I'm hoping that this
issue is one that will be fixed when the first set of patches comes
out, which should be very soon

--

Shaun Pond


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.