Highlighted
jmiller3 Absent Member.
Absent Member.
5390 views

Cannot log in: unable to connect to Zenworks database.

ZCM on SLES
Error: Unable to connect to the ZENworks database. Please ensure that the ZENworks database is running. One of the possible causes could be the database server IP address changed. Please see the documentation for manual steps required to fix the login issue associated with it.

Disk filled up, corrupting the database.
Restored the database from a good backup.
Still same error.
ran novell-zenworks-configure -c Start and stopped all services
ran again and started.
Got error about initial-web-service file not found
file should be in etc/opt/novell/zenworks
found intial-web-service.bak file. copied to initial-web-service

ran novell-zenworks-configure -c Start again and all service started successfully.

Still get the same error upon login..

any help appreciated..
Labels (2)
0 Likes
7 Replies
jmiller3 Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

Oh, yes, I did add disk space first...!
0 Likes
jmiller3 Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

Also, it is the standard built in internal Sybase database
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

Try deleting the transaction logs from the directory with the database.
Then restarting the database services.
Just a shot in the dark here.

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"jmiller3" <jmiller3@no-mx.forums.novell.com> wrote in message
news:jmiller3.40ikqp@no-mx.forums.novell.com...
>
> ZCM on SLES
> Error: Unable to connect to the ZENworks database. Please ensure
> that the ZENworks database is running. One of the possible causes could
> be the database server IP address changed. Please see the documentation
> for manual steps required to fix the login issue associated with it.
>
> Disk filled up, corrupting the database.
> Restored the database from a good backup.
> Still same error.
> ran novell-zenworks-configure -c Start and stopped all services
> ran again and started.
> Got error about initial-web-service file not found
> file should be in etc/opt/novell/zenworks
> found intial-web-service.bak file. copied to initial-web-service
>
> ran novell-zenworks-configure -c Start again and all service started
> successfully.
>
> Still get the same error upon login..
>
> any help appreciated..
>
>
> --
> jmiller3
> ------------------------------------------------------------------------
> jmiller3's Profile: http://forums.novell.com/member.php?userid=28059
> View this thread: http://forums.novell.com/showthread.php?t=390342
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

Oh, And Hope over to the Sybase Forums.
http://www.sybase.com/support/community-forums

AFAIK, they are free to access.

While they will not know ZCM, they should have a good idea about what to do
in cases like this.

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
news:a6kEm.206$5Q1.145@kovat.provo.novell.com...
> Try deleting the transaction logs from the directory with the database.
> Then restarting the database services.
> Just a shot in the dark here.
>
> --
> Craig Wilson - MCNE, MCSE, CCNA
> Novell Knowledge Partner
>
> Novell does not officially monitor these forums.
>
> Suggestions/Opinions/Statements made by me are solely my own.
> These thoughts may not be shared by either Novell or any rational human.
>
>
> "jmiller3" <jmiller3@no-mx.forums.novell.com> wrote in message
> news:jmiller3.40ikqp@no-mx.forums.novell.com...
>>
>> ZCM on SLES
>> Error: Unable to connect to the ZENworks database. Please ensure
>> that the ZENworks database is running. One of the possible causes could
>> be the database server IP address changed. Please see the documentation
>> for manual steps required to fix the login issue associated with it.
>>
>> Disk filled up, corrupting the database.
>> Restored the database from a good backup.
>> Still same error.
>> ran novell-zenworks-configure -c Start and stopped all services
>> ran again and started.
>> Got error about initial-web-service file not found
>> file should be in etc/opt/novell/zenworks
>> found intial-web-service.bak file. copied to initial-web-service
>>
>> ran novell-zenworks-configure -c Start again and all service started
>> successfully.
>>
>> Still get the same error upon login..
>>
>> any help appreciated..
>>
>>
>> --
>> jmiller3
>> ------------------------------------------------------------------------
>> jmiller3's Profile: http://forums.novell.com/member.php?userid=28059
>> View this thread: http://forums.novell.com/showthread.php?t=390342
>>

>
>



0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

Actually, you will need to try this after renaming the Transaction Log.

"dbeng10 mydatabase.db -f"

If that starts the DB Service then run "dbstop".

Then try starting the service normally.


--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
news:E8kEm.211$5Q1.183@kovat.provo.novell.com...
> Oh, And Hope over to the Sybase Forums.
> http://www.sybase.com/support/community-forums
>
> AFAIK, they are free to access.
>
> While they will not know ZCM, they should have a good idea about what to
> do in cases like this.
>
> --
> Craig Wilson - MCNE, MCSE, CCNA
> Novell Knowledge Partner
>
> Novell does not officially monitor these forums.
>
> Suggestions/Opinions/Statements made by me are solely my own.
> These thoughts may not be shared by either Novell or any rational human.
>
>
> "Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
> news:a6kEm.206$5Q1.145@kovat.provo.novell.com...
>> Try deleting the transaction logs from the directory with the database.
>> Then restarting the database services.
>> Just a shot in the dark here.
>>
>> --
>> Craig Wilson - MCNE, MCSE, CCNA
>> Novell Knowledge Partner
>>
>> Novell does not officially monitor these forums.
>>
>> Suggestions/Opinions/Statements made by me are solely my own.
>> These thoughts may not be shared by either Novell or any rational human.
>>
>>
>> "jmiller3" <jmiller3@no-mx.forums.novell.com> wrote in message
>> news:jmiller3.40ikqp@no-mx.forums.novell.com...
>>>
>>> ZCM on SLES
>>> Error: Unable to connect to the ZENworks database. Please ensure
>>> that the ZENworks database is running. One of the possible causes could
>>> be the database server IP address changed. Please see the documentation
>>> for manual steps required to fix the login issue associated with it.
>>>
>>> Disk filled up, corrupting the database.
>>> Restored the database from a good backup.
>>> Still same error.
>>> ran novell-zenworks-configure -c Start and stopped all services
>>> ran again and started.
>>> Got error about initial-web-service file not found
>>> file should be in etc/opt/novell/zenworks
>>> found intial-web-service.bak file. copied to initial-web-service
>>>
>>> ran novell-zenworks-configure -c Start again and all service started
>>> successfully.
>>>
>>> Still get the same error upon login..
>>>
>>> any help appreciated..
>>>
>>>
>>> --
>>> jmiller3
>>> ------------------------------------------------------------------------
>>> jmiller3's Profile: http://forums.novell.com/member.php?userid=28059
>>> View this thread: http://forums.novell.com/showthread.php?t=390342
>>>

>>
>>

>
>



0 Likes
jmiller3 Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

THIS REPAIRED THE Db and allowed ZCM to work again.

used novell-zenworks-config -c Start to stop, then start all ZCM services and it went back to work...

Thanks so much for the help...

Jan Miller


Craig Wilson;1877542 wrote:
Actually, you will need to try this after renaming the Transaction Log.

"dbeng10 mydatabase.db -f"

If that starts the DB Service then run "dbstop".

Then try starting the service normally.


--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
news:E8kEm.211$5Q1.183@kovat.provo.novell.com...
> Oh, And Hope over to the Sybase Forums.
> Community Forums/Newsgroups - Support & Services - Sybase Inc
>
> AFAIK, they are free to access.
>
> While they will not know ZCM, they should have a good idea about what to
> do in cases like this.
>
> --
> Craig Wilson - MCNE, MCSE, CCNA
> Novell Knowledge Partner
>
> Novell does not officially monitor these forums.
>
> Suggestions/Opinions/Statements made by me are solely my own.
> These thoughts may not be shared by either Novell or any rational human.
>
>
> "Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
> news:a6kEm.206$5Q1.145@kovat.provo.novell.com...
>> Try deleting the transaction logs from the directory with the database.
>> Then restarting the database services.
>> Just a shot in the dark here.
>>
>> --
>> Craig Wilson - MCNE, MCSE, CCNA
>> Novell Knowledge Partner
>>
>> Novell does not officially monitor these forums.
>>
>> Suggestions/Opinions/Statements made by me are solely my own.
>> These thoughts may not be shared by either Novell or any rational human.
>>
>>
>> "jmiller3" <jmiller3@no-mx.forums.novell.com> wrote in message
>> news:jmiller3.40ikqp@no-mx.forums.novell.com...
>>>
>>> ZCM on SLES
>>> Error: Unable to connect to the ZENworks database. Please ensure
>>> that the ZENworks database is running. One of the possible causes could
>>> be the database server IP address changed. Please see the documentation
>>> for manual steps required to fix the login issue associated with it.
>>>
>>> Disk filled up, corrupting the database.
>>> Restored the database from a good backup.
>>> Still same error.
>>> ran novell-zenworks-configure -c Start and stopped all services
>>> ran again and started.
>>> Got error about initial-web-service file not found
>>> file should be in etc/opt/novell/zenworks
>>> found intial-web-service.bak file. copied to initial-web-service
>>>
>>> ran novell-zenworks-configure -c Start again and all service started
>>> successfully.
>>>
>>> Still get the same error upon login..
>>>
>>> any help appreciated..
>>>
>>>
>>> --
>>> jmiller3
>>> ------------------------------------------------------------------------
>>> jmiller3's Profile: NOVELL FORUMS - View Profile: jmiller3
>>> View this thread: Cannot log in: unable to connect to Zenworks database. - NOVELL FORUMS
>>>

>>
>>

>
>
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Cannot log in: unable to connect to Zenworks database.

Great! I'm very glad it helped!

--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.


"jmiller3" <jmiller3@no-mx.forums.novell.com> wrote in message
news:jmiller3.40oc5e@no-mx.forums.novell.com...
>
> THIS REPAIRED THE Db and allowed ZCM to work again.
>
> used novell-zenworks-config -c Start to stop, then start all ZCM
> services and it went back to work...
>
> Thanks so much for the help...
>
> Jan Miller
>
>
> Craig Wilson;1877542 Wrote:
>> Actually, you will need to try this after renaming the Transaction Log.
>>
>> "dbeng10 mydatabase.db -f"
>>
>> If that starts the DB Service then run "dbstop".
>>
>> Then try starting the service normally.
>>
>>
>> --
>> Craig Wilson - MCNE, MCSE, CCNA
>> Novell Knowledge Partner
>>
>> Novell does not officially monitor these forums.
>>
>> Suggestions/Opinions/Statements made by me are solely my own.
>> These thoughts may not be shared by either Novell or any rational
>> human.
>>
>>
>> "Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
>> news:E8kEm.211$5Q1.183@kovat.provo.novell.com...
>> > Oh, And Hope over to the Sybase Forums.
>> > 'Community Forums/Newsgroups - Support & Services - Sybase Inc'

>> (http://www.sybase.com/support/community-forums)
>> >
>> > AFAIK, they are free to access.
>> >
>> > While they will not know ZCM, they should have a good idea about what

>> to
>> > do in cases like this.
>> >
>> > --
>> > Craig Wilson - MCNE, MCSE, CCNA
>> > Novell Knowledge Partner
>> >
>> > Novell does not officially monitor these forums.
>> >
>> > Suggestions/Opinions/Statements made by me are solely my own.
>> > These thoughts may not be shared by either Novell or any rational

>> human.
>> >
>> >
>> > "Craig Wilson" <craig_d_wilson@yahoo.com> wrote in message
>> > news:a6kEm.206$5Q1.145@kovat.provo.novell.com...
>> >> Try deleting the transaction logs from the directory with the

>> database.
>> >> Then restarting the database services.
>> >> Just a shot in the dark here.
>> >>
>> >> --
>> >> Craig Wilson - MCNE, MCSE, CCNA
>> >> Novell Knowledge Partner
>> >>
>> >> Novell does not officially monitor these forums.
>> >>
>> >> Suggestions/Opinions/Statements made by me are solely my own.
>> >> These thoughts may not be shared by either Novell or any rational

>> human.
>> >>
>> >>
>> >> "jmiller3" <jmiller3@no-mx.forums.novell.com> wrote in message
>> >> news:jmiller3.40ikqp@no-mx.forums.novell.com...
>> >>>
>> >>> ZCM on SLES
>> >>> Error: Unable to connect to the ZENworks database. Please ensure
>> >>> that the ZENworks database is running. One of the possible causes

>> could
>> >>> be the database server IP address changed. Please see the

>> documentation
>> >>> for manual steps required to fix the login issue associated with

>> it.
>> >>>
>> >>> Disk filled up, corrupting the database.
>> >>> Restored the database from a good backup.
>> >>> Still same error.
>> >>> ran novell-zenworks-configure -c Start and stopped all services
>> >>> ran again and started.
>> >>> Got error about initial-web-service file not found
>> >>> file should be in etc/opt/novell/zenworks
>> >>> found intial-web-service.bak file. copied to initial-web-service
>> >>>
>> >>> ran novell-zenworks-configure -c Start again and all service

>> started
>> >>> successfully.
>> >>>
>> >>> Still get the same error upon login..
>> >>>
>> >>> any help appreciated..
>> >>>
>> >>>
>> >>> --
>> >>> jmiller3
>> >>>

>> ------------------------------------------------------------------------
>> >>> jmiller3's Profile: 'NOVELL FORUMS - View Profile: jmiller3'

>> (http://forums.novell.com/member.php?userid=28059)
>> >>> View this thread: 'Cannot log in: unable to connect to Zenworks

>> database. - NOVELL FORUMS'
>> (http://forums.novell.com/showthread.php?t=390342)
>> >>>
>> >>
>> >>
>> >
>> >

>
>
> --
> jmiller3
> ------------------------------------------------------------------------
> jmiller3's Profile: http://forums.novell.com/member.php?userid=28059
> View this thread: http://forums.novell.com/showthread.php?t=390342
>



0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.