jfeyen Contributor.
Contributor.
1938 views

Creating UEFI image - Trying to make GPT based image from BI

Hello,

We put our system in UEFI mode.

Then installed Windows 10 , done sysprep.

Now we are trying to make an image via img -> we now have 4 GPT partitions
/dev/sda1 - NTFS 500MB
/dev/sda2 - Win95 FAT32 100MB
/dev/sda3 - MRP 16 MB
/dev/sda4 - NTFS 121488MB

-> as soon as we try to take an image of the all the partitions expect MRP partion , we get the following error:
https://www.novell.com/support/kb/doc.php?id=7014252
Trying to make GPT based image from BIOS machine.

However the our station is in UEFI mode.

How can we now take an image? We are stuck now.

Kr,

Joeri
Labels (1)
0 Likes
13 Replies
jfeyen Contributor.
Contributor.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi,

I found a solution:
You must take the image in PXE with UEFI network stack (can be enabled in the BIOS).

From then ZENworks launches the imaging in UEFI mode and images can be made without any error.

Kr,

Joeri
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi Joeri,

I had the same problem and after solving it as you have I got a different problem. The imaging process worked flawless but as soon as the syspreped W10 image started up it got stuck in the rotating dotted line and it never came out of it. Have you experienced this problem?

System information:
The image was made in VirtualBox with EFI turned on and has Windows 10 Enterprise LTSB 2016 as a OS.
The image was then installed on a Clevo N130WU (8th generation Core i5 with WD Black 256 GB NVMe ssd in UEFI mode).

Regards,

David
0 Likes
jfeyen Contributor.
Contributor.

Re: Creating UEFI image - Trying to make GPT based image fro

printerman;2483573 wrote:
Hi Joeri,

I had the same problem and after solving it as you have I got a different problem. The imaging process worked flawless but as soon as the syspreped W10 image started up it got stuck in the rotating dotted line and it never came out of it. Have you experienced this problem?

System information:
The image was made in VirtualBox with EFI turned on and has Windows 10 Enterprise LTSB 2016 as a OS.
The image was then installed on a Clevo N130WU (8th generation Core i5 with WD Black 256 GB NVMe ssd in UEFI mode).

Regards,

David


Hi David,

Yes, you have to change the boot order on the laptop after imaging.
Change the boot order from IPV4 to Windows Boot Loader.

Kr,

Joeri
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi Joeri,

Thanks for the advice but it didn't work. Windows should start the hardware detection but the only thing I see is the rotating dotted line.

Regards,

David
0 Likes
jfeyen Contributor.
Contributor.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi David,

Make sure that you have the lastest imaging driver update & uploaded the tuxera driver again.

Then create the image again and try to restore it .

Kr,

Joeri
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi Joeri,

I am running Zenworks 2017 update 2, with June PRU. Just saw the July PRU so I am updating to that version now but I do not think this is the problem. It looks like the imaging process is working fine because I do not get any error during the process and the hard drive partitions are correct after imaging. If I install Windows 10 Enterprise LTSB 2016 directly on the Clevo from usb-stick everything works perfectly. It is anoying to say the least.

Regards,

David
0 Likes
jfeyen Contributor.
Contributor.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi David,

Make sure you imaging is up to date , I had to do that too:
https://download.microfocus.com/Download?buildid=8ldKc0_IgwU~

After the imaing driver update, reupload the tuxera driver:
If Monthly driver updates includes new kernel version updates user has to re-upload the tuxera (NtfsDriver) driver from ZCC page.

Kr,

Joeri
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi Joeri,

I hadn't seen the ZENworks2017U2_March2018 update. I didn't bother to look for it because someone from Microfocus had told me that all updates are now coming through the Zenworks Configuration, System updates tab. After applying the update and reinstalling the Tuxera-driver the image installs correctly on the laptop.

Thanks for the help. Now I can go on holiday knowing I can get the image to work on UEFI-systems:cool:

Regards,

David
0 Likes
jfeyen Contributor.
Contributor.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi David,

Glad I could help and that you got it working!

Have great holidays!

Kr,

Joeri
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi Joeri,

Thanks, and have great holiday yourself.

Regards,

David
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

Hi Joeri,

Sorry, to bother you again. The imaging of the base image went well but the addon-images will not install. It returns the error: could not mount source/destination partition. Strangely, before the update I could install all the addon-images onto the base image without a problem. Do you know if something has changed in respect to addon-images? I cannot find anything on the www or in the readme.

Regards,

David
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Creating UEFI image - Trying to make GPT based image fro

There has not been any change around add-on images

printerman;2483596 wrote:
Hi Joeri,

Sorry, to bother you again. The imaging of the base image went well but the addon-images will not install. It returns the error: could not mount source/destination partition. Strangely, before the update I could install all the addon-images onto the base image without a problem. Do you know if something has changed in respect to addon-images? I cannot find anything on the www or in the readme.

Regards,

David
0 Likes
printerman Absent Member.
Absent Member.

Re: Creating UEFI image - Trying to make GPT based image fro

CRAIGDWILSON;2483609 wrote:
There has not been any change around add-on images


Hi Craig,

Today I tried something that sprung into my mind on Friday after work.

The add-on images I was using were made from the base image used on BIOS machines. Today I made a new add-on image from the base image for UEFI machines (the one I made on Friday with the updated imaging drivers) and this worked perfectly when installing it on a laptop.

So, problem solved. Thank you all for your help.

Regards,

David
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.