ktm_2000 Absent Member.
Absent Member.
5727 views

Failed to Process Action:Object reference not set to an ...

Here's the full error message:

Failed to process action: Object reference not set to an instance of an object.

I'm trying to set a portion of an IE zones policy which has to be set per user in HKCU. The only action in the bundle is the registry change and under advanced it is set to run action as USER.

Any idea what is going on, HKCU registry edits used to be simple under zen7 , ZCM11 not so much..........
Labels (2)
0 Likes
14 Replies
Obiwan1 Absent Member.
Absent Member.

Re: Failed to Process Action:Object reference not set to an

Hello,

"HKCU registry edits used to be simple under zen7 , ZCM11 not so much.......... "

The problem is: There are more options regarding rights and different things about the timing (well - sometimes I still miss the application order 😉 )

I have a similar thing, a single bundle doing different things (e.g. registry settings) in HKLM and HKCU:

- it's assigned to workstations
- it runs at user login (as there's a part really running under user's security)
- it uses different security settings for the different partial actions
- if I need to write into user's registry in one of the "policies"-keys: I use "Run action as System" and "Apply HKEY_CURRENT_USER changes to the logged in user's hive instead of .DEFAULT" (as I need to have enough rights as User, if I remember this one wasn't possible in ZDM7 and earlier)

I can't remember (the last check i did was with 10.2) what happens if you try to run a part as user while no one is logged in yet--I'm trying to avoid this:)

Dirk
0 Likes
Popopinsel Absent Member.
Absent Member.

Re: Failed to Process Action:Object reference not set to an

We have exactly the same error message on some of our bundles and this is really making us go insane!

The error occurs at the step at which an executable file on a Micosoft Windows network share (\\xxx.xxx.xxx.xxx\File.exe) is launched as dynamic administrator with network credentials from the credential vault. Strange thing is that it does occur totally random but mostly when the Workstation has been up and running for quiet a time. The only way to (sometimes) workaround this problem is to reboot the Workstation.

Here's the full error message:

The handler Novell.Zenworks.ActionManager.GenericActions.LaunchActionHandler thew the following exception: System.NullReferenceException: Object reference not set to an instance of an object. at Novell.Zenworks.ActionManager.ActionManUtil.OpenORCloseRemoteConnection(ActionContext context, String[] dirPaths, String CredentialsVaultID, String Imper


We desperately NEED a fix for this as soon as possible!
0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

Popopinsel,
> We have exactly the same error message on some of our bundles and this
> is really making us go insane!


So is this 11 or 11.1? If 11 have you installed the ZAC Client patch 2?

- Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Novell has a new enhancement request system,
or what is now known as the requirement portal.
If customers would like to give input in the upcoming
releases of Novell products then they should go to
http://www.novell.com/rms

0 Likes
Popopinsel Absent Member.
Absent Member.

Re: Failed to Process Action:Object reference not set to an

AndersG;2140207 wrote:
So is this 11 or 11.1? If 11 have you installed the ZAC Client patch 2?


Hi Anders,

thanks for your answer, we're on ZCM 11.1.

In the meantime I found a workaround for the problem by using a simple AutoIt script. It launches the application via AutoIt's built-in RunAs function to use network credentials (logon_flag="2"). I then use ZENworks' dynamic admin to start that compiled AutoIt script. Works like a charm!

But anyway, you seriously should eloborate on that problem. It's just not acceptable that we're depending on 3rd party software every now and then.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

Popopinsel,
> But anyway, you seriously should eloborate on that problem. It's just
> not acceptable that we're depending on 3rd party software every now and
> then.


Absolutely. I have forwarded it to Novell. But for them to look at it, we
need logs so can you please enable debug logging, clear the log, then do
whatever you need to do to make the error happen, then upload the log to
ftp.novell.com/incoming under a suitable, unique name and tell me?


- Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Novell has a new enhancement request system,
or what is now known as the requirement portal.
If customers would like to give input in the upcoming
releases of Novell products then they should go to
http://www.novell.com/rms

0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

BBZBiel,
> Are there any news about that problem?


I have not received any logs so there has been no progress at this end,
sorry.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
BBZBiel Absent Member.
Absent Member.

Re: Failed to Process Action:Object reference not set to an

I replicated the error (run an installation script from an nss volume as dynamic administrator with some credentials for network access) and made a debug log level report. It's uploaded to ftp.novell.com/incoming under the name "BBZBiel_zeninfo_zcm11_error_network_credentials.zip". Thanks for your help.

AndersG;2186958 wrote:
BBZBiel,
> Are there any news about that problem?


I have not received any logs so there has been no progress at this end,
sorry.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms
0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

BBZBiel,
> I replicated the error (run an installation script from an nss volume as
> dynamic administrator with some credentials for network access) and made
> a debug log level report. It's uploaded to ftp.novell.com/incoming under
> the name "BBZBiel_zeninfo_zcm11_error_network_credentials.zip". Thanks
> for your help.


Perfect. Let me have someone from Novell look at it.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

Novell asks:

"do we know the format he used for those credentials?"

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
BBZBiel Absent Member.
Absent Member.

Re: Failed to Process Action:Object reference not set to an

We created a new credential (ZENworks Controler Center - Configuration - Credential Vault) with the login name in format .Username.CONTEXT

AndersG;2187230 wrote:
Novell asks:

"do we know the format he used for those credentials?"

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Failed to Process Action:Object reference not set to an ...

It may be this issue........
http://www.novell.com/support/viewContent.do?externalId=7000565

An official patch does not yet exist.

Take a LAN Trace while duping the issue.

If there is not any Network Authentication Request while launching the
bundle, it is likely the same issue.

If there is, there is some other issue causing the authentication to fail.

On 4/4/2012 7:26 AM, BBZBiel wrote:
>
> We created a new credential (ZENworks Controler Center - Configuration -
> Credential Vault) with the login name in format .Username.CONTEXT
>
> AndersG;2187230 Wrote:
>> Novell asks:
>>
>> "do we know the format he used for those credentials?"
>>
>> --
>> Anders Gustafsson (NKP)
>> The Aaland Islands (N60 E20)
>>
>> Have an idea for a product enhancement? Please visit:
>> http://www.novell.com/rms

>
>



--
Craig Wilson - MCNE, MCSE, CCNA
Novell Knowledge Partner

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

"
In the docu it states that the following format should be used:
.username.ou.o so he is missing the O at the end.
"

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
BBZBiel Absent Member.
Absent Member.

Re: Failed to Process Action:Object reference not set to an

Sorry for being imprecise about that. We are using the format .username.ou.o, so the format shouldn't be the problem.

I will now follow Craig's advice and take a LAN trace to check if there is a network authentication request or not. I'll let you know about the results.

AndersG;2187417 wrote:
"
In the docu it states that the following format should be used:
.username.ou.o so he is missing the O at the end.
"

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms
0 Likes
Knowledge Partner
Knowledge Partner

Re: Failed to Process Action:Object reference not set to an ...

BBZBiel,
> Sorry for being imprecise about that. We are using the format
> .username.ou.o, so the format shouldn't be the problem.
>
> I will now follow Craig's advice and take a LAN trace to check if there
> is a network authentication request or not. I'll let you know about the
> results.


OK.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.