RPummel Absent Member.
Absent Member.
1598 views

How to disable the Tuxera driver and not have it revert

We really want to use the native imaging driver and not the Tuxera driver, but we made the mistake of deploying the Tuxera driver a while back and cannot get it to stay turned off.

We are using ZCM 11.3.2. We have 2 primary servers and about 17 satellites. We use our satellites for imaging.

I have tried following the instructions in the ZCM 11 SP3 documentation for disabling the Tuxera Driver, which includes editing HighPerfDriver.conf and deleting "ntfsdriver-RANDOMNUMBER.zip" on each imaging server. However, on the windows satellites, each time I reboot after making the changes, the HighPerfDriver.conf goes right back to the way it was. The file modified date is the date/time of the reboot. I can't figure out what is going on. Ideas?

Rick P
Labels (2)
Tags (1)
0 Likes
7 Replies
Micro Focus Expert
Micro Focus Expert

Re: How to disable the Tuxera driver and not have it revert

It is likely coming back from the Sat Server's Parent Primary
0 Likes
RPummel Absent Member.
Absent Member.

Re: How to disable the Tuxera driver and not have it revert

So, how does one stop that from happening or change what is being replicated?
0 Likes
RPummel Absent Member.
Absent Member.

Re: How to disable the Tuxera driver and not have it revert

The HighPerfDriver.conf file on the primary server was edited a long time ago to comment out the Tuxera driver, and those edits are still intact. I just checked to make sure. However, the HighPerfDriver.conf file on the satellites is still being updated with a version of the file that does not have the driver commented out.

We have had a similar problem before, where an different version of the TFTP files was being replicated to satellites and overwriting what we had put in place, even though we had no TFTP replication schedule. We have never been able to figure out where on the primary this is coming from and how to make it stop or change what is being replicated. Any help on this would be hugely appreciated.

I can open a ticket with NTS, if need be.

Rick P
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: How to disable the Tuxera driver and not have it revert

Ticket may be best.
My guess is that something odd is happening.
Most likely, there is an old replication bundle still running and not being replaced since it is not configured.
You may want to try configuring replication and ensuring the parent is correct.

There could be other ways to make sure the old replication bundles go away IF that is what is happening, but I don't want to delve into that on a forum.
0 Likes
RPummel Absent Member.
Absent Member.

Re: How to disable the Tuxera driver and not have it revert

OK, I just created a SR with Novell.
0 Likes
RPummel Absent Member.
Absent Member.

Re: How to disable the Tuxera driver and not have it revert

Novell support helped me figure out the problem. Now, the Tuxera driver has been removed from our satellite imaging servers, and PXE booting is working normally again.

The Tuxera config file (HighPerfDriver.conf) was getting recreated from a zip file on the satellite.

The instructions in the official ZCM 11 SP3 documentation for disabling the Tuxera driver are not quite complete. Here is what you really need to do, assuming that you want to use the native imaging driver:
1. On the Windows satellite server, delete the following file: C:\Program Files (x86)\Novell\ZENworks\share\tftp\HighPerfDriver.conf
2. To keep the above file from re-appearing, delete all the zip files in the following folder:C:\Program Files (x86)\Novell\ZENworks\work\content-repo\tmp\imaging\
3. Reboot the satellite

That's all!
0 Likes
RPummel Absent Member.
Absent Member.

Re: How to disable the Tuxera driver and not have it revert

Well, actually . . .

I found that workstations were not able to PXE boot after doing the three simple steps I outlined. There must be some Tuxera thing hanging around still, because as far as I know, before the Tuxera driver is installed, there is no HighPerfDriver.conf file.

After some testing, here are the actual steps that seem to work:
1. On the Windows satellite server, open the following file in a rich text editor such as WordPad: C:\Program Files (x86)\Novell\ZENworks\share\tftp\HighPerfDriver.conf
2. Comment out any lines that begin with "NTFSDriver" by adding a # symbol at the beginning of each line. Save and close. Note that the end result is a file that contains only comments, no active lines. However, if you delete the file, then PXE booting will likely stop working.
3. To keep the above changes from reverting, delete all the zip files in the following folder:C:\Program Files (x86)\Novell\ZENworks\work\content-repo\tmp\imaging\. Note that you cannot move the files into a subdirectory (e.g. ...tmp\imaging\backup\). I tried, and your changes to the .conf file continue to get overwritten during a reboot.
4. Reboot the satellite.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.