Highlighted
normand Trusted Contributor.
Trusted Contributor.
300 views

Imaging with PXE over IPv4 UEFI

Jump to solution

Hi,

Booting in PXE over IPv4 on UEFI devices isn't working when devices are on another subnet than my ZCM server.

Legacy PXE booting is working fine on all subnets.

Do I have to add a scope option on my DHCP server ?

Thanks for help.

Normand

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Micro Focus Expert
Micro Focus Expert

Re: Imaging with PXE over IPv4 UEFI

Jump to solution

Remove Options 60, 66, and 67.

Configure IP Helper Addresses for your Proxy-DHCP Server.

Your ZCM Proxy-DHCP Server will deliver that information

0 Likes
6 Replies
Micro Focus Expert
Micro Focus Expert

Re: Imaging with PXE over IPv4 UEFI

Jump to solution

See - https://www.novell.com/documentation/zenworks-2017-update-4/pdfdoc/zen_cm_preboot_imaging/zen_cm_preboot_imaging.pdf

Start with the bottom of page 61 - Configuring a WAN/VLAN With Preboot Services and DHCP Running on
Separate Servers

#1 - Make sure your DHCP Server is NOT delivering any Bootfile information.

#2 - Make sure the IP Helper Address forwards to your ZCM Imaging Server that is running Proxy-DHCP.

That server will then forward the Bootfile information.

0 Likes
normand Trusted Contributor.
Trusted Contributor.

Re: Imaging with PXE over IPv4 UEFI

Jump to solution

Craig,

I configured Option 60 in my DHCP server scope but it looks like that setting unactivate settings that were configured for PXE in Legacy mode.  Now, Legacy mode devices cannot receive DHCP IP address in PXE.

Both options cannot coexist ?

Thanks.

Normand

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Imaging with PXE over IPv4 UEFI

Jump to solution

There documented way of configuring the network for Imaging has not changed between BIOS and UEFI.

Some unsupported and undocumented methods could work with BIOS....Normally no changes are required to introduce UEFI if the docs were followed.  (The documented configuration method has not changed in this regard going back to ZENworks for Desktops back in the Windows NT 4.0 days....)

DHCP Option 60 is only supposed to be enabled if your Imaging Server is hosted on the same server as your main DHCP Server.

I Presume you could install Windows DHCP Servers on the Same Server as your ZCM Primary.....but nobody does that....so in reality...DHCP Option 60 is not supposed to be defined when your DHCP Server is one box. (Likely a Networking Appliance of Some Type) and your ZCM Imaging server is another box.

 

0 Likes
normand Trusted Contributor.
Trusted Contributor.

Re: Imaging with PXE over IPv4 UEFI

Jump to solution

Craig,

That's what I have in my DHCP configuration.  I add option 60 to be able to boot in PXE in UEFI mode.

Capture.JPG

0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Imaging with PXE over IPv4 UEFI

Jump to solution

Remove Options 60, 66, and 67.

Configure IP Helper Addresses for your Proxy-DHCP Server.

Your ZCM Proxy-DHCP Server will deliver that information

0 Likes
normand Trusted Contributor.
Trusted Contributor.

Re: Imaging with PXE over IPv4 UEFI

Jump to solution
Craig,

There was an old ZCM server ip helper address configured in our router. We changed that address for the existing ZCM server and now everything is working without any DHCP options.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.