Much Absent Member.
Absent Member.
840 views

Migrate appliance 11.4.2 to 2017 - warning prerequisite step

Hello,

I have the problem, that the appliance migration is not running because some prerequisite steps are missing. I followed the documentation and i have a open SR but maybe someone in this forum has the same problem and can help me with this.
The support has no solution at the moment and i'm waiting for a remote support.

We have two 11.4.2 appliances. We want to upgrade/migrate to 2017 so i followed the docu and asked the support for the correct steps. We have a seconds hard disk mounted and the image-repo is mounted to a cifs share.

I did the prerequirements (run zdc and installed the novell-zenworks-prereq-0.1-1.noarch.rpm on the 11.4.2 appliance).
Both runs without any error.

I shutdown both primary servers. I started with the primary that has the internal db.

I deployed the 2017 appliance to our vm environment and make a copy of the vmdk file (11.4.2) and attached this vmdk to the 2017 appliance.
Now i powered on the 2017 appliance and the vm is booting. After a few seconds i get the warning, that some prerequisite steps are missing on the 11.4.2 appliance. You can see the warning attached.



There is no information about the steps that are missing and i find no other prerequirements that are necessary.
Has someone else a problem like this?

Thanks and Greeting
Labels (1)
0 Likes
7 Replies
Knowledge Partner
Knowledge Partner

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Did you see the following in the docs:

Migrating the appliance to ZENworks 2017 might not continue if any of the ZENworks products are in active license state with Evaluation mode, but does not have a valid license key for ZENworks 2017. Before starting the migration, check the ZENworks 2017 licenses available in the Micro Focus Customer Center portal and deactivate the products that does not have ZENworks 2017 license, and then proceed with the migration.


Unsure if that has anything to do with this error but maybe worth a check.

https://www.novell.com/documentation/zenworks2017/zen_upgrade/data/brivl5j.html

Thomas
0 Likes
Much Absent Member.
Absent Member.

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Hi Thomas,

thanks for your reply. I read this lines but i was not thinking about it because i thought is all ok.

This information is about the license status in the zcc, right? This looks like this in our config:


We have in the micro focus service center only keys for ZCM and not for ZPM - maybe thats the problem, right.
I will give the support this information.

Greeting
Steffen
0 Likes
Knowledge Partner
Knowledge Partner

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Much;2469975 wrote:
Hi Thomas,

thanks for your reply. I read this lines but i was not thinking about it because i thought is all ok.

This information is about the license status in the zcc, right? This looks like this in our config:


We have in the micro focus service center only keys for ZCM and not for ZPM - maybe thats the problem, right.
I will give the support this information.

Greeting
Steffen


MIght be... Also check this TID: https://www.novell.com/support/kb/doc.php?id=7007955 It's a bit dated but it should get you there. Basically you at least 2 (3 if you use ZPM) different keys that need to be entered.

Thomas
0 Likes
Much Absent Member.
Absent Member.

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Hi Thomas,

i figured out what the problem is/was.

I did a snapshot on the 11.4.2 befor I run the zdc and rpm command. After that I shutdown the vm and copied the vmdk to the new appliance.
That was the problem – all changes that I made after the snapshot are not written to the vmdk – they are in the snaphshot file.
Now I deleted the snapshot and all changes are written to the vmdk. Then I copied the vmdk to the 2017 appliance and now I don’t get the warning again.

Maybe that will help some other people if they have this problem 🙂
0 Likes
Knowledge Partner
Knowledge Partner

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Much;2470079 wrote:
Hi Thomas,

i figured out what the problem is/was.

I did a snapshot on the 11.4.2 befor I run the zdc and rpm command. After that I shutdown the vm and copied the vmdk to the new appliance.
That was the problem – all changes that I made after the snapshot are not written to the vmdk – they are in the snaphshot file.
Now I deleted the snapshot and all changes are written to the vmdk. Then I copied the vmdk to the 2017 appliance and now I don’t get the warning again.

Maybe that will help some other people if they have this problem 🙂


Makes sense, thanks for sharing the solution and good luck with the upgrade!

Thomas
0 Likes
Much Absent Member.
Absent Member.

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Hi Thomas,

thanks - there is the next problem. Maybe you have a hint for me, too?

In 11.4.2 we had the following fstab entry to make a permanent mount:
//server-for-images /var/opt/novell/zenworks/content-repo/images cifs username=our-username,password=our-password

If I try this in 2017 there mount is not done. Do you have any idea what I doing wrong?
0 Likes
Much Absent Member.
Absent Member.

Re: Migrate appliance 11.4.2 to 2017 - warning prerequisite

Sorry - could not edit my post.
The solution was the parameter sec=ntlm
//server-for-images /var/opt/novell/zenworks/content-repo/images cifs sec=ntlm,username=our-username,password=our-password
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.