Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
bentinker Absent Member.
Absent Member.
1483 views

No logon for Win 10 after ZCM agent install via SCCM

We use SCCM for our OSD. During the task sequence we install the ZCM agent. Everything installs correctly, there are no errors, logs are clean, but once the machine comes up the Windows 10 (works fine on Win 7) logon screen is blank, there are no fields to enter credentials. If you boot to safe mode then login the problem is solved.

The issue exist on both 11.3 and 11.4.2 agent.

We’ve tried waiting for the istall using a script (http://christianlehrer.com/?p=226), installing the agent after the task sequence has finished (using SMSTSPostAction), using a custom agent with no zone details, nothing works. If we remove the ACM agent install form the task sequence the problem is goen.

Any ideas much appreciated.
Labels (2)
0 Likes
6 Replies
Micro Focus Expert
Micro Focus Expert

Re: No logon for Win 10 after ZCM agent install via SCCM

Does it work when NOT using this script?
(This script does not even look remotely valid FYI.......)

If so I would recommend looking here..........
https://www.novell.com/communities/coolsolutions/week-superlab-agent-deployment-using-active-directory-group-policy/

Looks like some graphics were lost, but the script is still here....
https://www.novell.com/communities/media/ClientInstall.zip

This same script could be used with SCCM instead of via a GPO.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
bentinker Absent Member.
Absent Member.

Re: No logon for Win 10 after ZCM agent install via SCCM

The ZCM agent installs without issue no matter how we do it, ie, with or without a script. There are no errors in the ZCM install log, and once you can log into the machine everything is fine. It's the win 10 login that is missing. If we remove the ZCM agent install from the SCCM task sequence the problem is gone.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: No logon for Win 10 after ZCM agent install via SCCM

If you manually install the ZCM Agent, does the issue return?
The script you posted is dangerous and invalid and terminates the install prior to completion.
Under no conditions should that script be used.
The ZCM install can be scripted, but the method in that script is very invalid.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
bentinker Absent Member.
Absent Member.

Re: No logon for Win 10 after ZCM agent install via SCCM

Okay, forget about the script. The script was only used as a test and not something we have used in the past.

There’s no issue if the agent is installed manually, but in order to do this windows has already been logged in to.
0 Likes
bentinker Absent Member.
Absent Member.

Re: No logon for Win 10 after ZCM agent install via SCCM

The best solution so far has been to copy the install to the local machine during the task sequence and add the RunOnce registry to launch it on first login.

cmd /c reg add HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnce /V "ZCM Agent" /t REG_SZ /d "C:\Temp\ZENworks\QFG000C7\PreAgentPkg_AgentComplete.exe -q"
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: No logon for Win 10 after ZCM agent install via SCCM

I could only suspect that SCCM may be rebooting, terminating the install prior to it's completion, or perhaps running another install at the same time causing installation issues, etc....
Furthermore, once has to be very careful when installing multiple packages that require a reboot w/o actually rebooting.
Locked files are updated using the PendingFileRenameOperations key.
If the same files is updated by multiple packages, it is possible that the most recent file may NOT be the one on the system at the end because Windows does the verification on the locked source and does not look to see if a newer version of that file is already flagged to be replaced.
--
Please give a hearty thumbs up to any post you find helpful!
To find articles by Craig Wilson simply follow the link: Craig Wilson's Tips!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.