Anonymous_User Absent Member.
Absent Member.
3274 views

Novell Preboot Policy Service -- Exits

Hi,

I have one Computer on my test environment, I have been imaging multiple
times over the weekend

however today, the Boot Agent just exits on PXE after talking to the
Preboot Policy Server

I have run ZISEDIT
I had DD the master boot record

The policy should be looking at the mac address (which hasn't changed
since working on the weekend) However it just implies that there is no
work to do (although it doesn't state no work to do)

I can manually image the PC using PXE and Maint Mode.

Any idea's what is causing the policy to fail.

Thanks

Pete
Labels (2)
0 Likes
3 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Novell Preboot Policy Service -- Exits

Peter Norris;2082902 wrote:
Hi,

I have one Computer on my test environment, I have been imaging multiple
times over the weekend

however today, the Boot Agent just exits on PXE after talking to the
Preboot Policy Server

I have run ZISEDIT
I had DD the master boot record

The policy should be looking at the mac address (which hasn't changed
since working on the weekend) However it just implies that there is no
work to do (although it doesn't state no work to do)

I can manually image the PC using PXE and Maint Mode.

Any idea's what is causing the policy to fail.

Thanks

Pete


Have you checked the logs, the answer might be found there:

Log Location:
Windows server:
%ZENWORKS_HOME%\logs\preboot\novell-proxydhcp.log
%ZENWORKS_HOME% \logs\preboot\novell-pbserv.log
%ZENWORKS_HOME% \logs\preboot\novell-tftp.log
%ZENWORKS_HOME% \logs\preboot\novell-zmgprebootpolicy.log
** %ZENWORKS_HOME%\logs\prebootlookup.log
Linux server:
/var/opt/novell/log/zenworks/preboot/novell-pbserv.log
/var/opt/novell/log/zenworks/preboot/novell-zmgprebootpolicy.log
/var/opt/novell/log/novell-proxydhcp.log
/var/opt/novell/log/novell-tftp.log
** /var/opt/novell/log/zenworks/prebootlookup.log

Thomas
0 Likes
Highlighted
Ghuebner Absent Member.
Absent Member.

Re: Novell Preboot Policy Service -- Exits

Hy Pete
Since ZCM 11 it is no longer possible to reimage a device by deleting image save date if the former device object exist in Zone. For Workstations nor exist in the Zone prebootlookup.log shows "Did not find any Dummy Workstation object based on MAC/SerialNumber"

There is no documantation about this and you coud not change this behavior. I open a SR, novell crates a bug (#673361).

Deleting the device object or Apply Rule-Based Imaging Bundle on the device object

regard

Gernot
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Novell Preboot Policy Service -- Exits

Hi Gernot,

I suspected, something along those lines, but got it working now by
deleting the object and doing a zisedit.

Thanks

On 03/08/2011 06:36 PM, Ghuebner wrote:
>
> Hy Pete
> Since ZCM 11 it is no longer possible to reimage a device by deleting
> image save date if the former device object exist in Zone. For
> Workstations nor exist in the Zone prebootlookup.log shows "Did not find
> any Dummy Workstation object based on MAC/SerialNumber"
>
> There is no documantation about this and you coud not change this
> behavior. I open a SR, novell crates a bug (#673361).
>
> Deleting the device object or Apply Rule-Based Imaging Bundle on the
> device object
>
> regard
>
> Gernot
>
>


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.