Highlighted
mmiller667 Absent Member.
Absent Member.
1007 views

OSX version bundle requirements.

Hello folks.

Is there a way to be more granular when targeting various OSX versions in a bundles requirements? Its easy enough to target various Major OSX versions using the "Mac Distribution" requirement. But I have some bundles that require a machine to be at 10.9.2 or later and I cant reach that level of granularity. Were running ZCM 11.3.1 w 11k workstations.

Any ideas?
Thanks!

-- Matt D. Miller Winnipeg School Division
Labels (2)
0 Likes
1 Reply
shaunpond Absent Member.
Absent Member.

Re: OSX version bundle requirements.

Mmiller667,

not being a Mac expert, I'm only guessing, but could you use a bundle
that used something like
mkdir /somedir/macver
rm /somedir/macver/*
echo test> /somedir/macver/$(sw_vers -productVersion)

in a bundle that you force run at the start, then check for the
presence of /somedir/macver/10.9.5 for example in your normal bundle?


--

Shaun Pond
newly reminted as a Knowledge Professional


0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.