akwyjibo Absent Member.
Absent Member.
1079 views

PC Lag, bundles failing when Action is "Run as Dynamic Admin

I have had an ongoing issue with running any bundle as Dynamic Admin in our environment. Almost all of workstations do not have admin rights.

I have been running every bundle with the action "Run as secure system user (Don't allow system to interact with desktop)" which has worked fine. However now we are using Patch management and many of the patches are configured to use Dynamic Admin. I worked with support on this a while ago and supposedly it was fixed in 11.3. I just upgraded to 11.3.1 and am still having the issue.

Here is the error I expect is behind the problem in the event viewer of the PC.

Category: BundleManager
BUNDLE.ChildActionError: The child bundle "Oracle Java JRE 1.7.0_67 for Windows (Update) (All-1420114589" failed due to the reason : There is no user session available or user session cannot be determined.. However, the parent bundle will continue to execute even though the child bundle has failed.

After the bundle fails I get extreme lag on the PC to the point where it's almost unusable. The PC eventually returns to normal after a long time. Obviously this terrifies me when I think about deploying patches to 450 computers.

Here is a TID I found which says it's fixed in the 11.2.4 MU1 update.

https://www.novell.com/support/kb/doc.php?id=7014157

Has anyone else seen this?
Labels (2)
0 Likes
2 Replies
Knowledge Partner
Knowledge Partner

Re: PC Lag, bundles failing when Action is "Run as Dynamic A

akwyjibo;2333791 wrote:
I have had an ongoing issue with running any bundle as Dynamic Admin in our environment. Almost all of workstations do not have admin rights.

I have been running every bundle with the action "Run as secure system user (Don't allow system to interact with desktop)" which has worked fine. However now we are using Patch management and many of the patches are configured to use Dynamic Admin. I worked with support on this a while ago and supposedly it was fixed in 11.3. I just upgraded to 11.3.1 and am still having the issue.

Here is the error I expect is behind the problem in the event viewer of the PC.

Category: BundleManager
BUNDLE.ChildActionError: The child bundle "Oracle Java JRE 1.7.0_67 for Windows (Update) (All-1420114589" failed due to the reason : There is no user session available or user session cannot be determined.. However, the parent bundle will continue to execute even though the child bundle has failed.

After the bundle fails I get extreme lag on the PC to the point where it's almost unusable. The PC eventually returns to normal after a long time. Obviously this terrifies me when I think about deploying patches to 450 computers.

Here is a TID I found which says it's fixed in the 11.2.4 MU1 update.

https://www.novell.com/support/kb/doc.php?id=7014157

Has anyone else seen this?


I've not seen this but we only recently started testing ZPM... What does it say in the debug zmd-messages log on the workstation? And which process is consuming cpu/memory/disk when your pc lags?

Best to have them reopen the SR since your issue is not fixed.

Thomas
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: PC Lag, bundles failing when Action is "Run as Dynamic Admin

Since this is related to patch bundles, normally I would suggest posting
in the patch forum.

However, I would recommend a new SR on the issue, rather than posting there.

Most likely you have a different root cause than the TID, even if they
result in the same error message.

Often folks will see an "error message" rather an a root cause.
This can lead them to falsely believe that all root causes are the same.


On 9/18/2014 9:36 AM, akwyjibo wrote:
>
> I have had an ongoing issue with running any bundle as Dynamic Admin in
> our environment. Almost all of workstations do not have admin rights.
>
> I have been running every bundle with the action "Run as secure system
> user (Don't allow system to interact with desktop)" which has worked
> fine. However now we are using Patch management and many of the patches
> are configured to use Dynamic Admin. I worked with support on this a
> while ago and supposedly it was fixed in 11.3. I just upgraded to 11.3.1
> and am still having the issue.
>
> Here is the error I expect is behind the problem in the event viewer of
> the PC.
>
> Category: BundleManager
> BUNDLE.ChildActionError: The child bundle "Oracle Java JRE 1.7.0_67 for
> Windows (Update) (All-1420114589" failed due to the reason : There is no
> user session available or user session cannot be determined.. However,
> the parent bundle will continue to execute even though the child bundle
> has failed.
>
> After the bundle fails I get extreme lag on the PC to the point where
> it's almost unusable. The PC eventually returns to normal after a long
> time. Obviously this terrifies me when I think about deploying patches
> to 450 computers.
>


>
> Has anyone else seen this?
>
>



--
Going to Brainshare 2014?
http://www.brainshare.com
Use Registration Code "nvlcwilson" for $300 off!


Craig Wilson - MCNE, MCSE, CCNA
Novell Technical Support Engineer

Novell does not officially monitor these forums.

Suggestions/Opinions/Statements made by me are solely my own.
These thoughts may not be shared by either Novell or any rational human.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.